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Bài 1
T NG QUAN V   PH N M M MS EXCEL 2K3Ổ Ề Ầ Ề

a. Đi u ki n tiên quy t:ề ệ ế
 S  d ng thành th o chu t và thao tác bàn phímử ụ ạ ộ
 Có ki n th c tin h c c  b n, th c hi n đ c thao tác qu n lí h  s  trên máy tính.ế ứ ọ ơ ả ự ệ ượ ả ồ ơ
 Có ki n th c và kĩ năng nh p văn b n ti ng vi t trên máy tính (s  d ng unikey (Vietkey),ế ứ ậ ả ế ệ ử ụ  

ch n mã và Font t ng ng b ng mã)ọ ươ ứ ả
b. M c tiêuụ

 Mô t  đ c quy trình và th c hi n đ c thao tác kh i đ ng, thóat kh i Excel.ả ượ ự ệ ượ ở ộ ỏ
 Mô t  và nêu đ c ý nghĩa các  thành ph n trên giao di n màn hình Excel 2K3 ả ượ ầ ệ
 Th c hi n đ c kĩ năng thao tác c  b n trên b ng tính (sheet) : di chuy n tr  chu t trênự ệ ượ ơ ả ả ể ỏ ộ  

sheet,  t o l p b ng tính, thao tác liên quan sheet, ô, dòng…ạ ậ ả
 Th c hi n các thao tác nh p d  li u ti ng vi t vào sheet, hi u chĩnh, xóa d  li u, ch n vùng,ự ệ ậ ữ ệ ế ệ ệ ữ ệ ọ  

copy, di chuy n d  li u…ể ữ ệ
 Th c hi n đ c thao tác liên quan đ nh d ng b ng tính : d  li u s , chu i, k  khung vi n, tôự ệ ượ ị ạ ả ữ ệ ố ỗ ẻ ề  

n n,…ề

c. N i dungộ
Microsoft Excel là ph n m m x  lý b ng tính ch y trên n n Windows do hãng Microsoftầ ề ử ả ạ ề  
s n xu t r t đ c thông d ng. Nó giúp ích cho ng i s  d ng trong vi c tính toán, x  lí sả ấ ấ ượ ụ ườ ử ụ ệ ử ố 
li u, th ng kê, trích l c thông tin ph c v  nhu c u h c t p, nghiên c u khoa h c, kinhệ ố ọ ụ ụ ầ ọ ậ ứ ọ  
doanh, qu n lí hành chính, s n xu t kinh doanh, …MS Excel 2K3 là m t ph n m m đ cả ả ấ ộ ầ ề ượ  
tích h p s n trong b  MS Office 2K3 khi cài đ t vào h  th ng máy tính.ợ ẵ ộ ặ ệ ố

I.  Kh i đ ng và thoát kh i Excel.ở ộ ỏ
1. Kh i đ ng:ở ộ

 Cách 1: Nh p đôi chu t vào bi u t ng Microsoft Excel trên màn hình. ấ ộ ể ượ
 Cách 2: Nh p chu t vào nút Start, ch n All  Programs > Microsoft  Office >ấ ộ ọ  

Microsoft Excel 2003
2. Thoát kh i Excel:ỏ

 Cách 1: Ch n File > Exit.ọ

 Cách 2: n t  h p phím Alt + F4 ho c g  t  h p phím Alt + F r i g  phím X.Ấ ổ ợ ặ ỏ ổ ợ ồ ỏ
 Cách 3: Nh p chu t vào nút Close ấ ộ   góc trên bên ph i màn hình.ở ả
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II. Màn hình làm vi c c a MS Excel 2K3ệ ủ

1. Thanh tiêu đ .ề
Hi n th  tên ng d ng và tên t p tin, các nút phóng to, thu nh  màn hình và nút Closeể ị ứ ụ ậ ỏ  
(thoát kh i Excel).ỏ

2. Thanh menu.
Tìm hi u các trình đ n (Menu) c a MS Excel 2K3.ể ơ ủ

File...................................... Ch a các l nh liên quan đ n thao tác trên t p tin b ng tínhứ ệ ế ậ ả
Edit .......................................Ch a các l nh liên quan đ n thao tác so n th o b ng tínhứ ệ ế ạ ả ả
Insert .............................................................Ch a các l nh liên quan đ n thao tác chènứ ệ ế
Format ......................................Ch a các l nh liên quan đ n thao tác đ nh d ng d  li uứ ệ ế ị ạ ữ ệ
Tools ........................................Ch a các l nh liên quan đ n m t s  công c  c a Excelứ ệ ế ộ ố ụ ủ
Data ..........................................Ch a các l nh liên quan đ n thao tác trên c  s  d  li uứ ệ ế ơ ở ữ ệ
Window ..............................................Ch a các l nh liên quan đ n thao tác trên c a sứ ệ ế ử ổ

Đ  m  m t menu, có th  ch n 1 trong 2 cách sau:ể ở ộ ể ọ
 Cách 1: Nh p chu t vào tên menu trên thanh th c đ n.ấ ộ ự ơ
 Cách 2: Nh n t  h p phím ALT + ký t  đ i di n tên menu (ký t  có g ch d i).ấ ổ ợ ự ạ ệ ự ạ ướ
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Ví du đ  m  menu File có th  n t  h p phím Alt+F r i g  phím Fể ở ể ấ ổ ợ ồ ỏ

3. Thanh công c  chu n (Standard)ụ ẩ

Ch a m t s  nút có tác d ng gíp thao tác nhanh khi làmvi c v i Excelứ ộ ố ụ ệ ớ

M t s  nút l nh thông d ng trên thanh công c  chu nộ ố ệ ụ ụ ẩ

Nút l nhệ Tên nút l nhệ T  h p phím t tổ ợ ắ Menu Công d ngụ
New Ctrl + N File > New M  m t b ng tính m iở ộ ả ớ

Open Ctrl + O, Ctrl + F12 File > Open M  m t b ng tính có s nở ộ ả ẳ

Save
Ctrl + S, hay 
Shift + F12

File > Save L u b ng tínhư ả

Print Ctrl + P File > Print In b ng tính hi n hànhả ệ

Print Preview Alt + F , V
File > Print 
Preview

Xem b ng tính tr c khi inả ướ

Cut Ctrl + X Edit > Cut C t  đã ch n vào Clipboardắ ọ

Copy Ctrl + C Edit > Copy
Sao chép kh i đã ch n vàoố ọ  
Clipboard

Paste Ctrl+ V Edit > Paste
Dán kh i đã ch n t  Clipboard raố ọ ừ  
bên ngoài

Format Painter Không có Không có Sao chép ki u đ nh d ngể ị ạ

Undo Ctrl + Z Edit > Undo
H y b  thao tác hi n hành, l pủ ỏ ệ ặ  
l i thao tác tr c đóạ ướ

Redo Ctrl + Y, F4 Edit > Repeat L p l i thao tác hi n hànhặ ạ ệ

Insert Hyperlink Ctrl + K
Insert > 
Hyperlink

Chèn m t siêu liên k t vào b ngộ ế ả  
tính

AutoSum Không có Không có Tính t ng t  đ ngổ ự ộ

Sort Ascending Không có Không có
S p x p d  li u trong vùng đ cắ ế ữ ệ ượ  
ch n theo th  t  tăng d nọ ứ ư ầ

Sort Descending Không có Không có
S p x p d  li u trong vùng đ cắ ế ữ ệ ượ  
ch n theo th  t  gi m d nọ ứ ư ả ầ

Drawing Không có
View > Toolbar 
> Drawing

B t/t t thanh công c  Drawingậ ắ ụ

Chart Wizard Alt + F1,  F11 Insert > Chart
Chèn bi u đ , đ  th  vào b ngể ồ ồ ị ả  
tính

4. Thanh công c  đ nh d ng (Formatting toolbar).ụ ị ạ

Ch a m t s  nút giúp th c hi n nhanh thao tác đ nh d ng c  b n khi s  d ng MS Excelứ ộ ố ự ệ ị ạ ơ ả ử ụ

M t s  nút l nh thông d ng trên thanh công c  đ nh d ngộ ố ệ ụ ụ ị ạ

Nút l nhệ Tên nút l nhệ T  h p phím t tổ ợ ắ Menu Công d ngụ

Font Ctrl + Shift + F
Format > Cells > 
Font

Ch n font ch  cho vùng d  li uọ ữ ữ ệ  
đ c ch nượ ọ

Font Size Ct5l + Shift + P
Format > Cells > 
Font

Ch n kích th c c a font chọ ướ ủ ữ

Bold Ctrl + B
Format > Cells > 
Font

B t/t t in đ m d  li uậ ắ ậ ữ ệ
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Italic Ctrl + I
Format > Cells > 
Font

B t/t t in nghiêng d  li uậ ắ ữ ệ

Underline Ctrl + U
Format > Cells > 
Font

B t/t t g ch d i d  li uậ ắ ạ ướ ữ ệ

Align Left Không có
Format > Cells > 
Alignment

Canh d  li u v  bên trái ôữ ệ ề

Center Không có
Format > Cells > 
Alignment

Canh d  li u  gi a ôữ ệ ở ữ

Align Right Không có
Format > Cells > 
Alignment

Canh d  li u v  bên ph i c a ôữ ệ ề ả ủ

Merge and 
Center

Không có
Format > Cells > 
Alignment

Tr n các ô đ c ch n thành 1 ôộ ượ ọ  
duy nh t và canh gi a d  li uấ ữ ữ ệ

Increase 
Decimal

Không có
Format > Cells > 
Number

Tăng s  l   ph n th p phânố ẻ ở ầ ậ

Decrease 
Decimal

Không có
Format > Cells > 
Number

Gi m s  l   ph n th p phânả ố ẻ ở ầ ậ

Decrease 
Indent

Không có Không có
Đ y d  li u v  bên trái ô hi nẩ ữ ệ ề ệ  
hành

Increase 
Indent

Không có Không có
Đ y d  li u v  bên ph i ô hi nẩ ữ ệ ề ả ệ  
hành

Borders Không có
Format > Cells > 
Borders

K  khung cho b ng tínhẻ ả

Fill Color Không có
Format > Cells > 
Patternns

Tô n n cho vùng d  li u đ cề ữ ệ ượ  
ch nọ

Font Color Không có
Format > Cells > 
Font

Ch n màu ch  trong vùng dọ ữ ữ 
li u đ c ch nệ ượ ọ

5. Thanh công th c (Formular)ứ

Thanh công th c là h p hi n th  d  li u b n nh p vào ô giúp chúng ta theo dõi quá trìnhứ ộ ể ị ữ ệ ạ ậ  
nh p d  li u vào ô. Thanh công th c hi n th  công th c t i ô đang tham chi u và giúp phânậ ữ ệ ứ ể ị ứ ạ ế  
bi t d  li u nh p vào ô là s  hay công th c. Ví d  trên, ô E2 là ô đang tham chi u, nhìnệ ữ ệ ậ ố ứ ụ ế  
vào ô th y con s  1,250,000 ( 1 tri u hai trăm năm mu i ngàn) nh ng nhìn  thanh côngấ ố ệ ơ ư ở  
th c, ta th y là =C2*D2 nên th c ch t d  li u t i E2 là công th c. Giá tr  t i E2 là k t quứ ấ ự ấ ữ ệ ạ ứ ị ạ ế ả 
c a công th c =C2*D2 =50000*25=1250000ủ ứ

6. Thanh cu n (Scroll bar).ộ
G m hai thanh cu n ngang và cu n d c dùng đ  xem n i dung ph n b  che khu t c aồ ộ ộ ọ ể ộ ầ ị ấ ủ  
b ng tính.ả

7. Thanh đi u h ng (navigation bar) ề ướ
có công d ng cho hi n tên sheet trong b ng tính khi có nhi u sheet do gi i h n b  r ngụ ệ ả ề ớ ạ ề ộ  
màn hình m i l n ch  hi n t i đa kh ang  7-9 sheet, các sheet còn l i b  che.ỗ ầ ỉ ệ ố ỏ ạ ị
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8. Thanh tr ng thái.ạ
Hi n th  tr ng thái hi n hành hay ý nghĩa l nh hi n hành c a Excel và các tình tr ngể ị ạ ệ ệ ệ ủ ạ  
c a h  th ng nh : Num Lock (ch  đ  s  d ng các phím s   bên ph i bàn phím),ủ ệ ố ư ế ộ ử ụ ố ở ả  
Caps Lock (ch  đ  gõ ch  hoa).ế ộ ữ

9.  B ng tính.ả

 M t t p tin b ng tính Excel (Workbook) g m nhi u b ng tính (Worksheets), cácộ ậ ả ồ ề ả  
Sheet có th  có tên riêng (m c đ nh là Sheet 1, Sheet 2, Sheet 3,.....)ể ặ ị

 M t Sheet là 1 b ng g m 256 c t (column) đ c ký hi u A, B, C,...., Z, AA, AB,....IVộ ả ồ ộ ượ ệ  
và 65536 dòng (row) đ c ký hi u 1, 2, 3, ...., 65536ượ ệ

 Khu v c giao nhau gi a 1 c t và 1 hàng đ c g i là 1 ô (cell). Trong Excel ô dùngự ữ ộ ượ ọ  
đ  l u tr  d  li u và cũng là đ n v  c  s  nh  nh t đ  x  lÍể ư ữ ữ ệ ơ ị ơ ở ỏ ấ ể ử  
c a b ng tínhủ ả

 T p tin b ng tính (Workbook) là t p tin mà b n có th  nh p,ậ ả ậ ạ ể ậ  
x  lí và l u tr  d  li u theo d ng b ng bao g m nhi u c tử ư ữ ữ ệ ạ ả ồ ề ộ  
và nhi u dòng.ề

 M t t p tin b ng tính (workbook) có th  ch a nhi u b ngộ ậ ả ể ứ ề ả  
tính (Worksheets). 

 T p tin b ng tính có th  đ c t o b i các ch ng trính x  lí b ng tính nh  ch ngậ ả ể ượ ạ ở ươ ử ả ư ươ  
trình MS Excel c a hãng Microsoft,  (Quattro pro - hãng Corel),…có ph n đuôi làủ ầ  
XLS. (ph n đuôi này đ c t  đ ng t o ra khi b n l u t p tin)ầ ựơ ự ộ ạ ạ ư ậ

 Đ a ch  (ký hi u) ô đ c ký hi u b i tên c t và dòng t ng ng.ị ỉ ệ ượ ệ ở ộ ươ ứ

Ví d :ụ  Ô A1 là ô (ph n giao)  c t A hàng 1, ô B3 là  c t B hàng 3ầ ở ộ ở ộ

 T p h p nhi u ô liên ti p t o thành hình ch  nh t g i là 1 vùng hay mi n (range),ậ ợ ề ế ạ ữ ậ ọ ề  
đ a ch  vùng đ c ký hi u b i đ a ch  ô phía trên bên trái (đ a ch  đ u) đ n ô phíaị ỉ ượ ệ ở ị ỉ ị ỉ ầ ế  
d i, bên ph i (đ a ch  cu i) c a vùng.ướ ả ị ỉ ố ủ

Ví d :ụ  
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N u mu n bi u di n ô, vùng  sheet khác thì ph i ghi tên sheet  phía tr c tên ô, vùng.ế ố ể ễ ở ả ở ướ
Ví d :ụ  Sheet2!A1, Sheet3!C1:C12

10. Kĩ năng thao tác ch n Font ch  vi t cho tòan b ng tínhọ ữ ệ ả
Đ  t t c  các ô trong b ng tính đ u hi n th  đ c fontể ấ ả ả ề ể ị ượ  
ch  vi t, b n nên th c hi n theo các b c sau:ữ ệ ạ ự ệ ướ

B1: Ch y b  g  bàn phím ti ng vi t ( hi n ch  V hay Eạ ộ ỏ ế ệ ệ ữ  
màu đ   góc ph i d i màn hình) ( nên s  d ngỏ ở ả ướ ử ụ  
unikey: click đôi bi u t ng UNIể ượ  trên màn hình 

B2: Ch n b ng mã ọ ả VNI windows ho c ặ unicode= cách 
click ph i nút ch  V màu đ , click ch n vniả ữ ỏ ọ  
windows ( ho c unicode), click ph i ch  V 1 l nặ ả ữ ầ  
n a r i ch n ki u g  VNI (ho c vni typing)ữ ồ ọ ể ỏ ặ

B3:  Click 1 sheet trong Excel, g  CTRL+A ho c clickỏ ặ  
nút bên trái c t A đ  ch n tòan b  b ng tínhộ ể ọ ộ ả  
(sheet)

B4: Ch n Font t ng ng v i b ng mã đã ch n  ọ ươ ứ ớ ả ọ ở B2

Ví d  1ụ  :   N u  b2ế ở , b n ch n b ng mã là VNI Windows, thìạ ọ ả  
mu n hi n ch  vi t trong b ng tính, c n ph i ch n cácố ệ ữ ệ ả ầ ả ọ  
font ch  có tên b t đ u là ữ ắ ầ VNI- nh  ư VNI-Avo, VNI-Helve, 
VNI-Times,…

Ví d  2ụ : N u  b2ế ở , b n ch n b ng mã là unicode, thìạ ọ ả   ph i ch n 1 trong các Font sau:ả ọ  
Arial, Tahoma, Verdana, Times New Roman, …

8
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1. KĨ NĂNG THAO TÁC QU N LÝ T P TIN B NG TÍNH.Ả Ậ Ả

1.1 M  m t t p tin b ng tính m i: ch n 1 trong 3 cách sau:ở ộ ậ ả ớ ọ

C1: Click nút New trên thanh Menu
C2: ch n menu File, click ch n Newọ ọ
C3: G  Ctrl + N  ( n và gi  phím CTRL, click r i nh  phím N)ỏ Ấ ữ ồ ả

1.2 L u m t t p tin b ng tính lên đĩa c ngư ộ ậ ả ứ  (m m): ch n 1 trong 3 cách sauề ọ

C1: Click nút Save    

C2:  G              +            ho c              ỏ ặ  +               

( n và gi  phím CTRL, click r i nh  phím S)Ấ ữ ồ ả

C3: Ch n menu File, click ch n Saveọ ọ

 S  hi n ra h p th ai Save As sau:ẽ ệ ộ ọ

9
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1.3 M  m t t p tin b ng tính đã có trên đĩa: ch n 1 trong 3 cách sauở ộ ậ ả ọ
 Click nút Open 
 Ctrl + O ho c Ctrl + F12 ho c ch n Menu File, click ch n l nh Openặ ặ ọ ọ ệ

Th c hi n ti p nh  h ng d n g i ý nh  hình sauự ệ ế ư ướ ẫ ợ ư

1.4 L u t p tin b ng tính v i tên m i và đ ng d n m i: ch n 1 trong 2 cáchư ậ ả ớ ớ ườ ẫ ớ ọ
File > Save As  ho c g  phím F12ặ ỏ

1.5 Đóng t p tin b ng tính đang m .: ch n 1 trong 3 cách sau:ậ ả ở ọ
 G  t  h p phím Ctrl + F4 hay Ctrl + Wỏ ổ ợ
 Ch n File  > Close ho c click nút close  góc ph i trên c a s  Excelọ ặ ở ả ử ổ

Bài t p áp d ng rèn luy n kĩ năng l u b ng tính, đóng b ng tính, m  fileậ ụ ệ ư ả ả ở  
b ng tính có s n trên đĩa:ả ẵ
Câu 1: Kh i đ ng Windows Explorer (g  lá c +E), Hãy t o th  m c tên BTEXCEL trên D:.ở ộ ỏ ờ ạ ư ụ  
Kh i đ ng Excel, ch y b  g  Unikey. ở ộ ạ ộ ỏ

 Ch n b ng mã là Unicode. G  CTRL+A, Ch n Font trong Excel là Arial.ọ ả ỏ ọ
 Nh p vào b ng tính sau: ậ ả
 L u b ng tính v i tên là BT1.xlsư ả ớ  

trong th  m c BTEXCELư ụ

Câu 2: Thóat kh i Excel (File > Exit)ỏ
Câu 3:  Kh i đ ng Excel, m  Fileở ộ ở  
BT1.XLS  trong  BTEXCEL.

Cách th c hi n:ự ệ   (xem m c 1.3)ụ

 Click nút Open trên menu hay g  CTRL+O.ỏ
 Click ch n đĩa D: r i click đôi tên th  m c BTEXCEL, s  hi n ra tên các file trongọ ồ ư ụ ẽ ệ  
BTEXCEL.
 Click đôi tên file BT1.XLS 

10
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2. M t s  kĩ năng thao tác liên quan đ n sheetộ ố ế
Thêm sheet, xóa sheet, đ i tên sheet, di chuy n sheet, sao chép sheetổ ể

2.1  Chèn thêm m t Sheet vào b ng tínhộ ả : 
ch n cách trên ho c cách th  2 dùng menu Insert,ọ ặ ứ  
click ch n Worksheetọ

2.2 Thao tác đ i tên Sheet trong b ngổ ả  
tính.

 Cách 1: Nh p đôi chu t vào tên Sheet c n đ i tên trên thanh phi u b ng tính, nh pấ ộ ầ ổ ế ả ậ  
tên m i và nh n Enter.ớ ấ

 Cách 2: click ph i tên sheet > click ch n rename, g  tên m i và enterả ọ ỏ ớ

 

 Cách 3: Click ch n Sheet c n đ i tên, Ch n Format > Sheet  > renameọ ầ ổ ọ   gỏ 
tên m iớ

11
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2.3 Kĩ năng thao tác xóa sheet trong b ng tính.ả

 Cách 1: click ph iả  vào tên sheet c n xóa, click ch n deleteầ ọ

 Cách 2: click ch n sheet c n xóa, click ch n menu Edit,  click ch n delete sheetọ ầ ọ ọ

3. Kĩ năng thao tác c  b n trong b ng tính (sheet)ơ ả ả

3.1 Di chuy n con tr  ô (tham chi u ô) trong b ng tínhể ỏ ế ả

 Cách 1: Nh p chu t vào ô mà ta mu n di chuy n con tr  đ n ô đó.ấ ộ ố ể ỏ ế

 Cách 2: Trong khi nh p d  li u cho b ng tính, có th  s  d ng phím nh  sauậ ữ ệ ả ể ử ụ ư

.............................................. di chuy n con tr  ô lên trên m t dòng.ể ỏ ộ

........................................... di chuy n con tr  ô xu ng d i m t dòng.ể ỏ ố ướ ộ

........................................... di chuy n con tr  ô qua ph i m t c t.ể ỏ ả ộ ộ

........................................... di chuy n con tr  ô qua trái m t c t.ể ỏ ộ ộ

               .................................... di chuy n con tr  ô lên trên m t trang màn hình.ể ỏ ộ

                           ........................ di chuy n con tr  ô xu ng d i m t trang màn hình.ể ỏ ố ướ ộ

                   +              ................ di chuy n con tr  ô qua trái m t trang màn hình.ể ỏ ộ

           +                  ............ di chuy n con tr  ô qua ph i m t trang màn hình.ể ỏ ả ộ

           +              ................ di chuy n nhanh con tr  ô v  ô A1.ể ỏ ề

Mu n di  chuy n con tr  đ n 1 ôố ể ỏ ế  
b t kì, có th  g  phím F5 r i nh pấ ể ỏ ồ ậ  
đ a ch  ô c n di  chuy n t i  trongị ỉ ầ ể ớ  
h p th ai go toộ ọ  OK
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Bài t p áp d ng v  thao tác sheet:ậ ụ ề

Câu 1: B n hãy th  đ i tên sheet1 thành TIN30, sheet2 thành TIN32A, sheet3 thànhạ ử ổ  
TIN32B.

Câu 2: Hãy chèn thêm 4 sheet n a. r i đ i tên 4 sheet này thành TIN33A, TIN33B, TIN29, TIN31ữ ồ ổ

Câu 3: Hày di chuy n các sheet đ  x p theo th  t  sheet t  trái sang ph i nh  sauể ể ế ứ ự ừ ả ư

Câu 3: Hãy xóa 2 sheet TIN33A và TIN33B. chèn thêm 4 sheet n a r i đ i tên 4 sheet nàyữ ồ ổ  
thành h c kì 1ọ , h c kì 2, h c kì 3, h c kì 4  ( mu n hi n ch  vi t tên sheet b nọ ọ ọ ố ệ ữ ệ ạ  
ch nmã unicode và Font Arial hay Tahoma.ọ

Câu 4: di chuy n 4 sheet c a câu 3 ra phía tr c.ể ủ ướ

Câu 5: l u file v a th c hi n v i tên là BT2.xls t i BTEXCEL.ư ừ ự ệ ớ ạ

3.2  Kĩ năng nh p d  li u trong b ng tính.ậ ữ ệ ả
Ch n ô c n nh p d  li u, gõ d  li u vào ô, nh n Enter ho c nh n phím mũi tênọ ầ ậ ữ ệ ữ ệ ấ ặ ấ  
ph i hay trái đ  hòan t t. ả ể ấ . Th  nh p dòng ch  trung tâm tin h c nh  sau:ử ậ ữ ọ ư

 N u nh p d  li u theo c t thì nên g  Enter sau khi nh pế ậ ữ ệ ộ ỏ ậ

Ghi chú: N i dung s  tràn qua ô bên ph i n u ô bên ph i (B1) là ô r ng. N i dung “ Trung tâm tinộ ẽ ả ế ả ỗ ộ  
h c “ tuy nhìn trên màn hình th y tin h c thu c v  ô B1 nh ng th c ra v n thu c ô A1.ọ ấ ọ ộ ề ư ự ẫ ộ

 N u nh p d  li u theo hàng ngang thì nên g  phím mũi tên ph i sau khi nh p dế ậ ữ ệ ỏ ả ậ ữ 
li uệ

ví d : g  STT r i g  phím         , g  ti p H  r i gõ ti p phím mũi tênụ ỏ ồ ỏ ỏ ế Ọ ồ ế

3.3 Thao tác chĩnh s a d  li u đã có trong ôử ữ ệ

 N u ch  mu n s a vài kí t  trong ô thì ch  c n click chu t vào ô r i click vào thanhế ỉ ố ử ự ỉ ầ ộ ồ  
công th c  (ho c click ch n ô, g  phím F2, ho c click đôi tr  chu t vào ô) r i dùngứ ặ ọ ỏ ặ ỏ ộ ồ  
phím lùi, Delete đ  xóa b  kí t  và nh p m i và g  Enterể ỏ ự ậ ớ ỏ

13
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 Mu n thay m i hòan tòan thông tin trong ô : ví d  ô A3 : click ch n ô A3 và nh p dồ ớ ụ ọ ậ ữ 
li u m i, g  Enter đ  hòan t t. ( thông tin m i s  thay th  thông tin có s n trong ô)ệ ớ ỏ ể ấ ớ ẽ ế ẵ

3.4Thao tác xóa d   li u trong ôữ ệ

 Xóa d  li u trong ô: click ch n ô, g  phím deleteữ ệ ọ ỏ
 Xóa d  li u 1 vùng: ch n vùng r i g  phím delete.ữ ệ ọ ồ ỏ
 Hãy thg  nh p b ng tính sau và xóa dòng th  4 nh  h ng d n nh  sau. Gử ậ ả ứ ư ướ ẫ ư ỏ 

CTRL+Z đ  h y b  thao tác v a th c hi nể ủ ỏ ừ ự ệ

3.5 Các ki u d  li u trong Excelể ữ ệ
D  li u nh p vào ô có th  là 1 trong 4 d ng sau : ữ ệ ậ ể ạ

3.5.1 D  li u ki u s  (number):ữ ệ ể ố

 Excel s  hi u n i dung nh p vào là ki u d  li u s   khi d  li u đó có ch a các s  tẽ ể ộ ậ ể ữ ệ ố ữ ệ ứ ố ừ 
0-9, ví trí ki u d  li u s  m c đ nh n m  bên ph i ô và có d ng General number.ể ữ ệ ố ặ ị ằ ở ả ạ

 Khi nh p có d u $  đ u thì s  s  có d ng Currency. ậ ấ ở ầ ố ẽ ạ

 Khi s  nh p quá l n thì s  s  có d ng Scientific (s  mũ) ví d  ố ậ ớ ố ẽ ạ ố ụ 1.23E+09. 

 D  li u s  là d  li u có th  tính tóan đ c : +, -, *, / ữ ệ ố ữ ệ ể ượ

 Khi con s  có đ  dài > đ  r ng ô thì s  hi n ra các d u thăng #######ố ộ ộ ộ ẽ ệ ấ

Ví d :ụ  1 con s  trong ô có th  hi n th   nhi u d ng : general ( s  nguyên), number (cóố ể ể ị ở ề ạ ố  
s  l  th p phân), scientific (s  KHKT), percent (%), date (ví d  dd/mm/yyyy), …ố ẻ ậ ố ụ

14
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3.5.2 D  li u ki u chu i (label hay string) là d  li uữ ệ ể ỗ ữ ệ
 G m các kí t  ch , kh ang tr ng và s  0..9 . Ví d  : 300nam là 1 chu iồ ự ữ ỏ ắ ố ụ ỗ
 Khi nh p d  li u s  vào ô, m c đ nh là n m bên trái c a ô. Ta có th  đ nhậ ữ ệ ố ặ ị ằ ủ ể ị  

d ng l i cho canh gi a hay trái.ạ ạ ữ
 D  li u chu i là d  li u không th  tính tóan v i d  li u s  đ c.ữ ệ ỗ ữ ệ ể ớ ữ ệ ố ượ
 Hãy th c t p nh p d  li u cho b ng tính nh  sau (ch a đ nh d ng, k  khung)ự ậ ậ ữ ệ ả ư ư ị ạ ẻ

Ghi chú: Khi nh p d  li u chu i trong ô, mu n vi tậ ữ ệ ỗ ố ế  
xu ng dòng trong ô có 2 cáchố

Cách 1:  Vi t xu ng dòng trong 1 ô = cách đ nh d ngế ố ị ạ  
wrap text cho ô

Cách 2:

 

3.5.3  Ki u ngày tháng (date) : ể

 Excel s  hi u là d  li u ẽ ể ữ ệ ki u ngàyể  n u ta nh p theo d ng dd/mm/yy ho c mm/dd/yyế ậ ạ ặ  
ho c 1 d ng khác tuỳ theo ki u ngày mà ta thi t l p trong Control Panel và Format >ặ ạ ể ế ậ  
Cells

15

Click ch n ô ọ B1, 
Ch n ọ Format > cell

Click Ch n Wrap textọ
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 D  li u ki u ngày đ c t  đ ng canh ph i ô .ữ ệ ể ượ ự ộ ả

 D  li u Ki u date theo 1 đ nh d ng nào đó th c ch t cũng là ki u s  vì khi b n nh pữ ệ ể ị ạ ự ấ ể ố ạ ậ  
vào 1 giá tr  d ng ngày/tháng/năm thì Excel s  l u bên trong b  nh  là 1 con sị ạ ẽ ư ộ ớ ố 
ngày tính t  1/1/1900 đ n date mà b n nh p vào. ừ ế ạ ậ

Ví d , khi b n nh p vào 12/2/2005, thì Excel th c ra l u vào s   38395 t c là ngày thụ ạ ậ ự ư ố ứ ứ 
38395 k  t  ngày 1/1/1900. Vì v y d  li u ki u Date cũng là ki u s  t c là có th  th c hi nể ừ ậ ữ ệ ể ể ố ứ ể ự ệ  
phép tính +, -, *, /  (c ng, tr , nhân, chia)ộ ừ

Ví d :ụ

Hãy th c t p nh p d  li u ki u ngày và đ nh d ng các ki u th  hi n ki u ngàyự ậ ậ ữ ệ ể ị ạ ể ể ệ ể  
nh  sau:ư

Đ nh d ng mm/dd/yyyyị ạ đ nh d ng dd/mm/yy (vietnamese)ị ạ

Trong ki u c a 1 qu c gia cũng có nhi u đ nh d ng khác nhauể ủ ố ề ị ạ

Đ  nh p d  li u ki u date theo vi t nam (Pháp) : dd/mm/yyyy (ngày/tháng/năm)ể ậ ữ ệ ể ệ

Ho c thay đ i ki u hi n th  date theo qu c gia, b n th c hi n theo các b c sau:ặ ổ ể ễ ị ố ạ ự ệ ướ

B1:  Tr  chu t v  trí b t kì trên b ng tính, ch nỏ ộ ị ấ ả ọ  
Start, click control panel

Trong c a s  control panel, click đôi bi u t ngử ổ ể ượ  
Regional and Language 

16

Vì d  li u t i 2 vùng B3:B5 vàữ ệ ạ  
C3:C5 là ki u Date nên đ  tính sể ể ố 
ngày : ta th c hi n phép tính:ở ự ệ  
=ngày đi-ngày . Công th c t i D3ở ứ ạ  
là : =C3-D3 r i ch n Format, clickồ ọ  
Cells, click ch n number, click ch nọ ọ  
general đ  chuy n v  d ng sể ể ề ạ ố 
nguyên.
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B2: Tô ch n các kh i ô c n chuy n sang đ nh d ng dd/mm/yyy (vietnamese),ọ ố ầ ể ị ạ  
ch n Format > cells r i th c hi n theo g i ý trong hình sauọ ồ ự ệ ợ

17
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3.5.4 Ki u công th c :ể ứ

 Excel s  hi u là d  li u ki u công th c khi ta nh p d  li u vào ô d ng ẽ ể ữ ệ ể ứ ậ ữ ệ ạ =bi u th cể ứ  
(bi u th c ph i nh p theo đúng qui đ nh c a Excel). ể ứ ả ậ ị ủ

 D  li u ki u công th c đ c t  đ ng canh trái hay canh ph i tùy thu c vào giá tr  trữ ệ ể ứ ượ ự ộ ả ộ ị ả 
v  c a bi u th c.ề ủ ể ứ

 Công th c b t đ u là d u “ = ” hay d u + sau đó là công th c c n l p. Trong côngứ ắ ầ ấ ấ ứ ầ ậ  
th c có th  là các s  c n tính (toán h ng), các hàm tính toán (s  đ c h c sau)ứ ể ố ầ ạ ẽ ượ ọ  
ho c các toán t  +, -, *, /ặ ử

Ví d : ụ

Cách th c hi n c t h  và tênự ệ ộ ọ : tr  chu t t i F2, g  =, click A2, g  d u &, g  phím “, thanhỏ ộ ạ ỏ ỏ ấ ỏ  
dài, phím “, g  d u &, click B2 r i Enter.ỏ ấ ồ

3.6 Kĩ năng thao tác liên quan đ n c t trong sheetế ộ

3.6.1 Kĩ năng thay đ i đ  r ng c t : cách s  d ng chu t thay đ i tr c ti pổ ộ ộ ộ ử ụ ộ ổ ự ế

3.6.2  Kĩ năng ch n m t c t.ọ ộ ộ

Cách 1: Nh p chu t vào tên c t c n ch nấ ộ ộ ầ ọ  
trên thanh tiêu đ  c t. (khi đó ta s  ch nề ộ ẽ ọ  
h n  65000 ô c a c t A)ơ ủ ộ

Cách 2: Di chuy n con tr  ô đ n m t ô b tể ỏ ế ộ ấ  
kì c a c t c n ch n, n ủ ộ ầ ọ ấ Ctrl + Spacebar.

3.6.3  Ch n nhi u c t liên ti p nhau.ọ ề ộ ế

Cách 1: Rê chu t t i các tên c t c n ch n trên thanh tiêu đ  c t.ộ ạ ộ ầ ọ ề ộ

18
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Cách 2: nh p chu t vào tên c t đ uấ ộ ộ ầ  
tiên c n ch n, n+gi  phím Shift vàầ ọ ấ ữ  
nh p  chu t  vào  tên  c t  cu i  cùngấ ộ ộ ố  
c n ch n trên thanh tiêu đ  c t, r iầ ọ ề ộ ồ  
nh  chu t ả ộ  nh  phím Shiftả

3.6.4 Ch n nhi u c t không liên ti p nhau.ọ ề ộ ế
Nh p chu t vào tên c t đ u tiên c n ch n, gi  phím Ctrl trong khi nh p chu t vào trên cácấ ộ ộ ầ ầ ọ ữ ấ ộ  
c t còn l i trên thanh tiêu đ  c t. Hãy th c t p ch n 2 c t A và c t B nh  sau:ộ ạ ề ộ ự ậ ọ ộ ộ ư

3.6.5 Chèn thêm c t m iộ ớ

3.6.6 Xóa c tộ

19

Cách 2: click ch n tên ọ
c t, ch n menu Insert > ộ ọ
column

Cách 2: click trái tên c t, ộ
ch n menu Edit > deleteọ
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3.6.7 Làm n (d u) c t:Ẩ ấ ộ
Cách 1: Click Ch n tên c t,  Ch n Format > Column, ch n Hide. Sau khi b  d u, tênọ ộ ọ ọ ị ấ  
c t không hi n trong b ng tính (ch  th y c t A và C, D, …c t B b  d u)ộ ệ ả ỉ ấ ộ ộ ị ấ

Cách 2: 

3.6.8 Hi n l i c t b  n: ệ ạ ộ ị ẩ
 Ch n các c t bên trái và bên ph i  c t b  nọ ộ ả ộ ị ẩ
 Format > column > Unhide  

20



H ng d n kĩ năng s  d ng MS Excel 2K3ướ ẫ ử ụ 21 

3.6.9 Cố đ nh dòng (c t):ị ộ
- Ch n dòng (c t) phía d i dòng c n c  đ nh (Ch n c t bên ph i c t c n cọ ộ ướ ầ ố ị ọ ộ ả ộ ầ ố 
đ nh)ị
- Window > Freeze Panes

3.6.10 H y b  vi c c  đ nh dòng:ủ ỏ ệ ố ị
- Ch n dòng hay c tọ ộ
- Window > Unfreeze Panes

3.7 Kĩ năng thao tác ch n dòng, thêm dòng, xóa dòng trong b ng tính: ọ ả

3.7.1 Kĩ năng thao tác ch n 1 dòng:ọ

N u mu n ch n nhi u dòng liên ti p nhau, click chu t ch n dòng th  1 và kéo chu t xu ngế ố ọ ề ế ộ ọ ứ ộ ố  
(lên) tên các dòng k  ti p  ( ví d  click ch n dòng s  2 kéo chu t xu ng ch n ti p dòng 3ế ế ụ ọ ố ộ ố ọ ế  
và 4 r i nh  chu t ồ ả ộ  ta ch n 3 dòng liên ti p 2, 3, 4ọ ế

3.7.2  Kĩ năng ch n nhi u dòng k  c n nhau trên b ng tínhọ ề ế ậ ả

3.7.3  Thay đ i chi u cao dòng: cách s  d ng chu t thay đ i tr c ti pổ ề ử ụ ộ ổ ự ế

3.7.4 Chèn thêm 1 dòng m iớ

cách 1: ch n 1 ô b t kì (Ví d  ch n ô ọ ấ ụ ọ B2) trong dòng 2, ch n Insert > row ọ  Excel sẽ 
chèn thêm 1 dòng m i phía trên dòng hi n t i. ớ ệ ạ
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cách 2: Thêm dòng m iớ

3.7.5 Chèn thêm nhi u dòng : ề

3.7.6 Xóa dòng  (d  li u trong dòng s  b  xóa luôn)ữ ệ ẽ ị

3.7.7  D u dòngấ

 Click ch n dòng c n d u, ch n Format > row, click Hideọ ầ ấ ọ

 Sau khi d u, trên b ng tính s  không th y dòng s  2.ấ ả ẽ ấ ố

22

Cách 2: click trái tên dòng, 
ch n menu Edit > deleteọ
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Cách 2: 

3.7.8 Hi n l i dòng b  d u trên b ng tínhệ ạ ị ấ ả
 Click trái ch n tên  dòng  bên trên và d i c a dòng b  n. ọ ướ ủ ị ẩ
 Ch n Format > Row, ch n UnHideọ ọ

3.8 Kĩ năng thao tác xóa ô, ch n 1 ho c nhi u vùng ọ ặ ề
3.8.1 Xóa  ô (cell)   d  li u trong ô s  b  xóa luônữ ệ ẽ ị

23
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N u ch n Entire row : s  xóa b  dòng đang ch a ô và xóa luôn d  li u dòng 2ế ọ ẽ ỏ ứ ữ ệ
N u ch n Entire column : s  xóa m t d  li u c t Bế ọ ẽ ấ ữ ệ ộ

3.8.2 Chèn thêm ô m i: click ch n ô ( ví d  ch n ô B2), ch n Insert sớ ọ ụ ọ ọ ẽ 
hi n h p th ai sauệ ộ ọ

3.8.3 Kĩ năng ch n m t vùng (nhi u ô liên ti p nhau)ọ ộ ề ế

Vùng là 1 kh i các ô liên ti p nhau trên sheet. Vùng đ c xác đ nh b i ố ế ượ ị ở đ a ch  đ u:ị ỉ ầ  
đ a ch  cu iị ỉ ố . Ví d :ụ

 Vùng A1:A5 g m 1 kh i có 5 ô liên ti p t  A1 (đ a ch  đ u) đ n A5 (đ a chồ ố ế ừ ị ỉ ầ ế ị ỉ 
cu i)ố

 Vùng A1:C4 g m 1 kh i có 12 ô  liên ti p t  A1 (đ a ch  đ u) đ n C4 (đ a chồ ố ế ừ ị ỉ ầ ế ị ỉ 
cu i)ố

Đ  ch n 1 vùng trên sheet, có th  ch  s  d ng chu t ho c k t h p chu t và phím shift,ể ọ ể ỉ ử ụ ộ ặ ế ợ ộ  
ho c ch  dùng phím mũi tên k t h p shiftặ ỉ ế ợ

 Cách 1  : Di chuy n con tr  ô đ n ô góc trên bên trái (đ a ch  đ u), n+ giể ỏ ế ị ỉ ầ Ấ ữ 
phím Shift r i dùng các phím mũi tên di chuy n v t sáng đ n ô  góc d i bênồ ể ệ ế ở ướ  
ph i c a vùng c n ch n (đ a ch  cu i).ả ủ ầ ọ ị ỉ ố

 Cách 2  : Di chuy n con tr  ô đ n ô góc trên bên trái (đ a ch  đ u), n+ giể ỏ ế ị ỉ ầ ấ ữ 
phím Shift r i nh p chu t vào   góc d i bên ph i c a vùng c n ch n. (đ a chồ ấ ộ ổ ở ướ ả ủ ầ ọ ị ỉ 
cu i).ố

 Cách 3  : Nh p chu t vào ô góc trên bên trái (đ a ch  đ u) c a vùng và rê chu tấ ộ ị ỉ ầ ủ ộ  
đ n ô  góc d i bên ph i (đ a ch  cu i).c a vùng c n ch n. Ví d  ta c n ch nế ở ướ ả ị ỉ ố ủ ầ ọ ụ ầ ọ  
vùng A1:C4
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3.8.4 Kĩ năng ch nọ  nhi u vùng r i r c (không liên t c)ề ờ ạ ụ

Ch n vùng đ u tiên, gi  Ctrl trong khi ch n các vùng còn l i.ọ ầ ử ọ ạ

3.8.5 Kĩ năng ch n toàn b  b ng tính.ọ ộ ả
Cách 1: n t  h p phím Ctrl + A ho c Ctrl + Shift +Spacebar.Ấ ổ ợ ặ

Cách 2: Nh p chu t vào ô Select All.ấ ộ

3.9 Kĩ năng sao chép d  li uữ ệ
Có nhi u cách sao chép d  li u t  1 ô đ n các ô khác. Ví dề ữ ệ ừ ế ụ

3.9.1 Sao chép thông tin t  ô A1 đ n các ô liên ti p bên d i hay bên ph i ô A1ừ ế ế ướ ả

3.9.2  Tr ng h p sao chép d c xu ng dùng t  h p phím CTRL+Dườ ợ ọ ố ổ ợ

Hãy th c t p th  thao tác t o nhi u ô có d  li u gi ng nhau nh  sau:ự ậ ử ạ ề ữ ệ ố ư
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3.9.3 Tr ngừờ  h p sao chép ngang qua ph iợ ả

Cách 2:  s  d ng  CTRL+C và CTRL+Vử ụ

Cách 3: s  d ng chu t k t h p phím CTRLử ụ ộ ế ợ

3.9.4 Tr ng h p sao chép 1 vùng đ n v  trí khác trong sheet:ườ ợ ế ị

B1:  Ch n vùng d  li u mu n sao chép r i ch n ọ ữ ệ ố ồ ọ Edit > Copy hay g  CTRL+Cỏ

B2:  click ch n sheet2, tr  chu t đ n ô đ u tiên c a sheet2, ọ ỏ ộ ế ầ ủ

B3:  g  CTRL+V hay ỏ Edit > Paste

Ví d  ta c n sao chép vùng A1:C4 đ n v  trí E1ụ ầ ế ị

26

Tô ch nọ  
vùng c nầ  
sao chép

Click  ô đ nế  
hay tên 
sheet2 ho cặ  
sheet bât kì
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3.9.5 Tr ng h p sao chép 1 vùng đ n v  trí khác trong sheet khác:ườ ợ ế ị

Ví d  c n sao chép vùng A1:C6 trongSheet1 qua A1 trong Sheet2ụ ầ

3.9.6  Sao chép theo chi u ngangề

3.10 Kĩ năng đi n t  đ ng s  th  t  trong 1 dãy ôề ự ộ ố ứ ự

cách 1:

Cách 2:  B n nên nh p d  li u đ y đ  nhi u dòng tr c khi đi n s  th  t  t  đ ng.ạ ậ ữ ệ ấ ủ ề ướ ề ố ứ ự ự ộ
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Hãy th c t pự ậ : Tr  ô A1, g  A001, enter r i g  A002 và Enter.  r i sao chép cho A3 đ nỏ ỏ ồ ỏ ồ ế  
A5.

3.11 Kĩ năng di chuy n d  li u trên b ng tính (sheet)ể ữ ệ ả

Cách 1: click ch n ô hay 1 vùng, g  CTRL+X-ọ ỏ  click ch n ô đích, g  CTRL+Vọ ỏ

Ví d  ta có b ng tính nh  hình d i đây: Đ  di chuy n vùng ụ ả ư ướ ể ể A1:C6 qua v  trí khác là ị E1: 
G6 th c hi n nh  sau: Tô ch n vùng ự ệ ư ọ A1:C6, g  CTRL+X ho c click nút cut ( hình cây kéoỏ ặ  
trên toolbar), click chu t ô E1, g  CTRL+X ho c click nút paste  bên ph i nút cây kéoộ ỏ ặ ở ả

Cách 2:  click ch n ô hay 1 vùng, tr  chu t vào 1 c nh c a ô hay vùng r i click chu t képọ ỏ ộ ạ ủ ồ ộ  
đ n v  trí m i trên sheetế ị ớ

Bài t p áp d ng sao chép và di chuy n d  li u trên b ng tínhậ ụ ể ữ ệ ả
Câu 1: Kh i đ ng Excel, đ i tên sheet1 là câu1.T o b ng tính nh  trên ở ộ ổ ạ ả ư
Câu 2:  chép vùng A1:B6 đ n ế A20. 

Câu 3:  chép vùng A1:C6 đ n ế F1. 

Câu 4:  chép vùng A2:B6 đ n ế A1 c a sheet2ủ  

Câu 5: Hãy chèn 2 dòng phía trên dòng 2 r i nh p b  sung h  lót, tên và đi m tóan cho 2ồ ậ ổ ọ ể  
dòng này.

 Chèn thêm 1 dòng tr ng  phía trên cùng c a b ng tính r i nh p  dòng ch  sau choố ở ủ ả ồ ậ ữ  
ô A1: DANH SÁCH SINH VIÊN L P TIN40Ớ

Câu 7: Hãy chèn thêm 1 c t bên trái c t h  lót r i nh p tên c t là STT.ộ ộ ọ ồ ậ ộ

 Đi n ề t  đ ngự ộ  s  th  t  t  1 đ n 7 cho các dòng trong b ng tínhố ứ ự ừ ề ả

 Chèn thêm 1 c t bên ph i c t Tên r i đ t tên cho c t này là ộ ả ộ ồ ặ ộ phái. Nh p b  sung tùyậ ổ  
ý d  li u cho c t phái này cho 7 dòng.ữ ệ ộ
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 KĨ NĂNG Đ NH D NG B NG TÍNHỊ Ạ Ả

4.1 Đ nh d ng b ng tính nghĩa là gì?ị ạ ả
Đ nh d ng đ c hi u là th c hi n thay đ i ki u, kích c , font ch , …d  li u trong sheet. làị ạ ượ ể ự ệ ổ ể ở ữ ữ ệ  
thao tác ch n Font ch , ki u, c  ch  (*size), thay đ i v  trí c a d  li u ki u chu i trong ô,ọ ữ ể ỡ ữ ổ ị ủ ữ ệ ể ỗ  
h ng trình bày d  li u chu i, hình th c hi n th  ki u d  li u s  trong b ng tính, ki u hi nướ ữ ệ ỗ ứ ể ị ể ữ ệ ố ả ể ễ  
th  ngày, gi , k  vi n, tô n n các kh i ô, b o v  d  li u trên b ng tính…ị ờ ẻ ề ề ố ả ệ ữ ệ ả

4.2 Kĩ năng đ nh d ng d  li u trong ô (canh trái, ph i, gi a, in đ m, nghiêng,ị ạ ữ ệ ả ữ ậ  
tô n n, k  vi nề ẻ ề

Đ  canh biên d  li u trong ô, ta th c hi n theo các b c sau:ể ữ ệ ự ệ ướ
B1:  Ch n ô ho c ch n vùng c n đ nh d ng canh biên.ọ ặ ọ ầ ị ạ
B2:  Nh p chu t vào m t trong các nút l nh trên thanh công c  đ nh d ngấ ộ ộ ệ ụ ị ạ

Hãy th c t p nh p b ngtính sau và l u lên đĩa v i tên là VATTU2007.XLS t i D:\ự ậ ậ ả ư ớ ạ

Ghi chú: 
D  li u s   c t s  l ng là ki u s , khi nh p m c đ nh là canh ph i c a ô. B n nên nh pữ ệ ố ở ộ ố ượ ể ố ậ ặ ị ả ủ ạ ậ  
t ng ô r i g  enter đ  tăng t c nh p d  li u thay vì nh p d  li u theo hàng ngangừ ồ ỏ ể ố ậ ữ ệ ậ ữ ệ

29

Tô ch n vùngọ  
C3:C12, click 
nút canh gi aữ

Click tô ch nọ  
vùng A2:F2, click 
nút canh gi a, inữ  
đ m, click nút tôậ  
n n ch n 1 màuề ọ  
nh t ạ

Dòng ch  này, ban đ u nh p t i A1, Click tô ch n vùng A1:F1, click nút tr n ô (Merge and center)ữ ầ ậ ạ ọ ộ  
Excel s  tr n 6 ô thành 1 ô và canh gi a dòng ch  “ Th ng kê v t t  trang b ”ẽ ộ ữ ữ ố ậ ư ị
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D  li u c t v t t  là d  li u ki u chu i, khi nh p vào t ng ô, d  li u t  đ ng canh trái. Khiữ ệ ộ ậ ư ữ ệ ể ỗ ậ ừ ữ ệ ự ộ  
c n thi t b n có th  đ nh d ng canh l  l i d  li u này: canh ph i, gi a,…ầ ế ạ ể ị ạ ề ạ ữ ệ ả ữ
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4.3  Đ  đ nh v  văn b n trong ô: ( phía trái, ph i, gi a,  nghiêng/quay ch  trong ô)ể ị ị ả ả ữ ữ

b1: ch n ô  hay vùng ch a d  li u c n đ nh d ng ọ ứ ữ ệ ầ ị ạ  ch n Format > cells t ng ngọ ươ ứ  
s  d ng các nút canh trái, gi a, ph i  trên thanh công c  đ nh d ng (Formatting)ử ụ ữ ả ụ ị ạ

Đ  đ nh v  d  li u trong vùng: ( phía trên, gi a, d i : theo chi u đ ng c a ô)ể ị ị ữ ệ ữ ướ ề ứ ủ

Hãy nh p b ng tính sau vàậ ả  
s  d ng ch c năng Format >ử ụ ứ  
cells đ  đ nh d ng b ng tínhể ị ạ ả  
nh  m uư ẫ

31

Đ  vi t xu ng dòng USD trong ô, đ  đi m chèn sau ch  ti n,ể ế ố ể ể ữ ề  
g  ALT+Enter đ  tách USD xu ng dòng trong ôỏ ể ố
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Đ  canh gi a ể ữ Tên hàng trong ô, click ch n ô Tên hàng, ch n ọ ọ Format > cells, th c hi nự ệ  
nh  g i ý trong hình sau:ư ợ

4.4Kĩ năng k  đ ng vi n, k  khung, tô n n.ẻ ườ ề ẻ ề
 Đ  k  đ ng vi n, k  khung hay tô n n cho ô ho c 1 vùng, ta làm nh  sau:ể ẻ ườ ề ẻ ề ặ ư

 Đ u tiên ph i ch n ô ho c vùng c n k  vi n hay tô n nầ ả ọ ặ ầ ẻ ề ề
Hãy nh p b ng tính sau và th c hành k  vi n và tô n n theo g i ý nh  sau: ậ ả ự ẻ ề ề ợ ư
Cách 1: s  d ng nút công c  trên toolbarsử ụ ụ

Đ  k  vi n b ng tínhể ẻ ề ả : Tô ch n vùng  ọ A2:F13 

Đ  tô n n 1 vùng:ể ề  Tô ch n vùng  ọ A2:F2
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Cách 2: s  d ng menu  đ  k  vi n cho ô hay kh i ôử ụ ể ẻ ề ố

Cách 2: Tô n n cho ô ho c 1 vùng b ng menu l nhề ặ ằ ệ

 click ch n Format > cells  (ho cọ ặ  
click ph i lên khôi ô đang ch n,ả ọ  
r i click ch n Format cells)ồ ọ

 Th c hi n nh  g i ý c a hình bênự ệ ư ợ ủ
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4.5Các thao tác đ nh d ng ị ạ dữ li u ki u s ,  Dateệ ể ố

Cách 1: Dùng các nút trên thanh công c  đ nh d ng (Formatting) đ  th c hi n cho nhanhụ ị ạ ể ự ệ
b1:  Ch n vùng d  li u c n đ nh d ngọ ữ ệ ầ ị ạ
b2:  Nh p chu t vào m t trong các bi u t ng đ nh d ng s  trên thanh công c  đ nh d ng.ấ ộ ộ ể ượ ị ạ ố ụ ị ạ

Cách 2: Dùng menu đ  đ nh d ng d  li u ki u sể ị ạ ữ ệ ể ố
Ví dụ: Đ nh d ng s  theo ki u ti n t , không có  ho c có s  l   ph n th p phân và cóị ạ ố ể ề ệ ặ ố ẻ ở ầ ậ  
ký hi u ti n t  đ  sau s . Tô ch n vùng  c n đ nh d ng có kí hi u ti n tệ ề ệ ở ố ọ ầ ị ạ ệ ề ệ
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4.6Đ nh d ng d  li u ị ạ ữ ệ date theo ki u vi t nam (Pháp): dd/mm/yyyy.ể ệ
Ch n vùng d  li u c n đ nh d ng ọ ữ ệ ầ ị ạ  ch n Format > cells (ho c g  CTRL+1)ọ ặ ỏ

4.7B O V  D  LI UẢ Ệ Ữ Ệ
 Ch n Sheet (vùng) c n b o v  ọ ầ ả ệ  Format > Cells
 Ch n tab Protectionọ
 Đánh d u ch n các m c Locked và Hidden -OKấ ọ ụ
 G i l nh Tools > Protectionọ ệ
 Ch n Protect sheet (ho c) Protect workbookọ ặ
 Gõ Password (m t kh u) 2 l nậ ẩ ầ
 Các ô b  lock (khoá) s  không cho phép s a ch a d  li uị ẽ ử ữ ữ ệ
 Các ô b  Hide ( n) ch  cho th y giá tr  (không th y công th c)ị ẩ ỉ ấ ị ấ ứ

4.8  Đ NH D NG D  LI U KI U S  TRONG Ô TH A ĐI U KI N NÀO ĐÓỊ Ạ Ữ Ệ Ể Ố Ỏ Ề Ệ
Trong b ng tính có r t nhi u d  li u, n u mu n cho n i b t nh ng con s  nào đó th aả ấ ề ữ ệ ế ố ổ ậ ữ ố ỏ  
đi u ki n nh m thu n ti n trong vi c quan sát, mô ph ng, so sánh ta c n cho nh ng ôề ệ ằ ậ ệ ệ ỏ ầ ữ  
đó có d ng hi n th  đ c bi t nào đó: ch  in đ m có màu đ , n n xanh ...ạ ể ị ặ ệ ữ ậ ỏ ề

Ví dụ: ta ch n màu n n đ  cho các ô có ĐTB <= 5 màu xanh, nh ng ô có giá tr  nhọ ề ỏ ữ ị ỏ 
h n màu đ .ơ ỏ

CÁCH TH C HI N:Ự Ệ
B1: Xác đ nh ị vùng d  li u c n đ nh d ng theo đi u ki n  nào đó.ữ ệ ầ ị ạ ề ệ
B2: Ch n menu ọ Format > Conditionnal  Formatting…
Đ  s  d ng các giá tr  trong kh i ô đã ch n làm tiêu chu n đ nh d ng, ta ch n ể ử ụ ị ố ọ ẩ ị ạ ọ Cell  
Value Is trong Condition 1 và ch n ki u so sánh (ọ ể between, greater than, equal, …), 
sau đó xác đ nh các giá tr  (hay công th c) trong các h p khai báo t ng ng.ị ị ứ ộ ươ ứ

B3: Click nút Format và ch n l a các đ nh d ng c n qui đ nh cho các ô th a đi u ki nọ ự ị ạ ầ ị ỏ ề ệ  
tiêu chu n. Đ  khai báo đi u ki n cho các đ nh d ng khác, click nút ẩ ể ề ệ ị ạ Add và th c hi nự ệ  
l i các b c nh  trên. Ta có th  đ nh đ n 3 đi u ki n đ nh d ng.ạ ướ ư ể ị ế ề ệ ị ạ
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Ví du: Đ nh d ng cho nh ng HS có đi m 10 có n n blue, in đ m, nghiêng.ị ạ ữ ể ề ậ

Ch n kh i ô t  C2 đ n F6. Vào ọ ố ừ ế Format > Conditional Formatting …

 Trong Condition 1 ch n ọ Cell Value Is.
 Ch n ki u so sánh laọ ể  equal to  giá tr  là ị 10.
 Click nút Format ,ch n ọ Font – Style là Bold italic, click th  ẻ Pattern, click  ch nọ  
màu blue, t i ạ color click ch n màu đ  r i OK.ọ ỏ ồ

Mu n ch n đi u ki n 2 là tô n n vàng s c nghiêng, ch  màu đ  đ i v i đi m <5, thì trongố ọ ề ệ ề ọ ữ ỏ ố ớ ể  
h p th ai trên click ch n Add và khai báo t ng t  nh  trênộ ọ ọ ươ ự ư
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BÀI T P 1: Nh p d  li u, k  khung tô n n, đ nh d ng d  li u: Ậ ậ ữ ệ ẻ ề ị ạ ữ ệ
Th c t p nh p d  li u, k  khung, tô n n vùng, chèn c t, đi n s  th  t  t  đ ngự ậ ậ ữ ệ ẻ ề ộ ề ố ứ ự ự ộ

Bài t p 2: ậ Nh p và đ nh d ng b ng tính nh  m u l u v i tên VATTU.XLS t i D:\ậ ị ạ ả ư ẫ ư ớ ạ

 H ng d n:  t o mướ ẫ ạ 3:  Tô s  3, ch n Format > Cells, click super scriptố ọ

37

Click ch n ô E3, g  d u =, click ọ ỏ ấ
Ô C3, g  d u * (d u nhân), click ỏ ấ ấ
ô D3, g  Enter s  có k t quỏ ẽ ế ả
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Bài t p 2 : Nh p và đ nh d ng b ng tính nh  m uậ ậ ị ạ ả ư ẫ : k  khung, tô n n nh  m u.ẻ ề ư ẫ

38

B1: G  H  và r i g  Alt+Enter, g  ti p Lót, Enter. Xong click đôi nút ỏ ọ ồ ỏ ỏ ế
cây c  r i click l n l t các ô C1, D1, E1, F1, G1, H1, I1, ọ ồ ầ ượ
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Bài t p 3:  ậ Nh p d  li u cho b ng tính sau và đ nh d ng nh  m u l u t i đĩa D:\ v iậ ữ ệ ả ị ạ ư ẫ ư ạ ớ  
tên THONGKE.XLS

1. Chèn thêm c t STT bên trái c t TÊN HÀNG r i đi n t  đ ng s  th  t  cho c t STTộ ộ ồ ề ự ộ ố ứ ự ộ
2. THÀNH TI N (USD)= (T ng C5:H5 ) * B5Ề ổ   (đ n giá). ( s  d ng đ a ch  t ng đ i)ơ ử ụ ị ỉ ươ ố
(click vào ô I5, g  vào =SUM( r i click ô C5 tô kéo qua H5, g  d u ngo c ), g  d u *, click ôỏ ồ ỏ ấ ặ ỏ ấ  
B2, g  Enter k t thúc.). Sao chép công th c này cho các ô I6 đ n I18)ỏ ế ứ ế
3. THÀNH TI N (VND)= I5 * J2Ề  ( t  giá). ( s  d ng đ a ch  tuy t đ i)ỉ ử ụ ị ỉ ệ ố
(click vào ô I5, g  vào = click ô I2, g  d u *, click J2 r i g  phím F4 đ  chuy n sang đ a chỏ ỏ ấ ồ ỏ ể ể ị ỉ 
tuy t đ i, g  Enter k t thúc.). Sao chép công th c này cho các ô I6 đ n I18)ệ ố ỏ ế ứ ế
4. Đ nh d ng c t THÀNH TI N  (USD) có kí hi u ti n t  $  phía tr c con s , có d uị ạ ộ Ề ệ ề ệ ở ướ ố ấ  

phân cách hàng ngàn ( xem trang 34, m c 4.2.4)ụ
5. Đ nh d ng c t THÀNH TI N  (VND) có kí hi u ti n t  “đ ng”  phía sau con s , có d uị ạ ộ Ề ệ ề ệ ồ ở ố ấ  

phân cách hàng ngàn.  (xem trang 34, m c 4.2.4)ụ
6. Đ nh d ng c t t  l  hi n th  d  li u s  d ng % có 2 s  l  . Ví d  : 2.23%, 1.44%ị ạ ộ ỉ ệ ể ị ữ ệ ố ạ ố ẻ ụ

( Tô ch n các ô c t t  l  : ọ ộ ỉ ệ K5:K19, click nút kí hi u % trên thanh đ nh d ng, ệ ị ạ
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Ph n đ nh d ng xu ng dòng này xem trang 28ầ ị ạ ố
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Bài t p 4:  ậ Nh p d  li u cho b ng tính sau và đ nh d ng nh  m u l u t i đĩa D:\ v i tênậ ữ ệ ả ị ạ ư ẫ ư ạ ớ  
BANGLUONGNV.XLS
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Câu h i ôn t pỏ ậ
1. Cột cuối cùng của bảng tính là cột thứ 256 có tên là 

cột   IV,   dòng   cuối   cùng   của  bảng   tính   là   dòng   thứ 
65536, vậy địa chỉ của ô này là  ____________

2. tổ hợp phím tương đương Menu lệnh  File > Exit là
     Cltrl  +  Esc       Ctrl   +   F4  
     Alt   +    F4       Alt   +    Tab 

3. Quan sát thanh menu, giữ phím  Alt  và gỏ 1 phím tương 
ứng với ký tự có gạch dưới trên thanh menu,  hiện tượng gì 
xảy ra ?

____________________________________________________________________________________________________

4. Trong cửa sổ bảng tính Excel, thanh trạng thái (Status  
bar) xuất hiện 

  cu i c a s  b ng tính.Ở ố ử ổ ả    đ u c a s  b ng tính.ở ầ ử ổ ả

5. Trên màn hình cửa sổ bảng tính Excel của máy tính  
bạn đang sử dụng, hiện ra bao nhiêu dòng, cột ?

kí hi u t  ch  _____ đ n ch  ______ . Có t t c  ________ c tệ ừ ữ ế ữ ấ ả ộ
ghi t  s   _______ đ n s  _______. Có t t c  ________ dòngừ ố ế ố ấ ả

6. Hãy ấn các tố hợp phím sau và ghi lại kết quả xảy ra
 Ctrl   +      _________________________________________________________________________________________

 Ctrl   +      _________________________________________________________________________________________

7. Trỏ chuột ô A1, Nhập  vào dòng chữ: “ Trung tâm tin 
học”, enter. Di chuyển nhanh đến ô A30, nhập CĐSP, 
enter.  Di  chuyển nhanh đến  ô  D80,  nhập  “khoa   tin 
học”, enter. Hãy ấn tổ hợp phím sau đây và ghi lại kết 
quả xảy ra

Ctrl   +   Home   ____________________________________________________________________________________

Ctrl   +   End   ______________________________________________________________________________________

8. Click chu t ch n sheet1, n và gi  phím CTRL, Click kéoộ ọ Ấ ữ  
sheet1 qua ph i và nh  chu t.ả ả ộ

Nhân xét k t qu .  Rút ra k t lu n thao tác sao chép nhanh 1 sheet.ế ả ế ậ

9. CH n Tools > Options, click ch n th  View, click ch n ọ ọ ẻ ọ   
Gridlines. Nh n xét k t qu . ậ ế ả
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Câu h i tr c nghi m t  ôn t p ki n th c và kĩ năng s  d ngỏ ắ ệ ự ậ ế ứ ử ụ  
EXCEL2K3

1. Đ  kh i đ ng Excel trên Windowể ở ộ
a. Nh p đúp con tr  chu t lên bi u t ng l i t t c a Excelấ ỏ ộ ể ượ ố ắ ủ
b. Nh p ch n Start > Program > Microsoft Office > Excelấ ọ
c. Nh p ch n Start > Run > gõ Excel > OKắ ọ
d. Câu a, b, c đ u đúngề

2. Đ  thoát kh i Excelể ỏ
a. Nh p menu đi u khi n, ch n Closeấ ề ể ọ c. Ch n menu File > Exitọ
b. Nh n t  h p phím Alt + F4ấ ổ ợ d. T t c  các câu đ u đúngấ ả ề

3. Thoát kh i ch ng Excel ta ch  vi c:ỏ ươ ỉ ệ
a. Nh n t  h p phím Alt + F4ấ ổ ợ c. Ch n menu File > closeọ
b. b m nút Resetấ d. t t máyắ

4. Mu n c c ti u màn hình Excel, taố ự ể
a. Nh p vào nút c c ti u trên thanh tiêu đấ ự ể ề b. Nh p vào menu đi u khi n r i ch n Minimizeấ ề ể ồ ọ
c. Nh p vào nút hình ch  X trên thanh tiêu đấ ữ ề d. Câu a và b đ u đúngề

5. Trong Excel mu n b t/ t t thanh công cố ậ ắ ụ
a. Ch n Tools > Options > Generalọ c. Ch n View > Tools Barọ
b. Ch n View > Formula barọ d. T t c  các câu đ u đúngấ ả ề

6. Ch n câu phát bi u đúng nh tọ ể ấ
a. Trong Excel không có menu t tắ
b. Menu t t là m t t  h p x  xu ng ch a các câu l nh có th  có c a m t m c ho c đ i t ng đ c tác đ ngắ ộ ổ ợ ổ ố ứ ệ ể ủ ộ ụ ặ ố ượ ượ ộ
c. T  h p phím t t g i l nh tác đ ng lên đ i t ng đã đ c ch n g i là menu t tổ ợ ắ ọ ệ ộ ố ượ ượ ọ ọ ắ
d. Menu t t là cách g i khác c a các h p tho i x  xu ng trên thanh công cắ ọ ủ ộ ạ ổ ố ụ

7. Thanh công th c c a Excelứ ủ
a. Xu t hi n trên c a s  màn hình (khi đ c đánh d u ch n)ấ ệ ử ổ ượ ấ ọ
b. Hi n th  công th c đã chèn vào ô (n u có)ể ị ứ ế
c. Ch  hi n th  các nút l nh khi đang th c hiên vi c chèn hàm vào ô hi n hànhỉ ể ị ệ ự ệ ệ
d. T t c  đ u đúngấ ả ề

8. Đ  b t/ t t thanh công th cể ậ ắ ứ
a. Ch n View > Formula Barọ
b. Ch n View > Tools Bar > Full Screenọ
c. Ch n View > Tools Bar > Formula Barọ
d. Không c n làm gì c , thanh công th c m c đ nh luôn xu t hi n trên c a s  màn hình Excelầ ả ứ ặ ị ấ ệ ử ổ

9. Khi mu n b t t t thanh tr ng tháiố ậ ắ ạ
a. Ch n Tools > Options > Generalọ c. Ch n View > Tools Barọ
b. Ch n View > Status Barọ d. T t c  các câu đ u đúngấ ả ề

10. Đ  s p x p nhi u c a s  t p tin đã m  khi làm vi cể ắ ế ề ử ổ ậ ở ệ
a. Nh n t  h p phím Alt + W, Aấ ổ ợ c. Ch n Window > New Windowọ
b. Ch n Data > Sortọ d. Câu a và c đ u đúngề

11. Ta th c hi n các câu l nh GoTo b ng cáchự ệ ệ ằ
a. Nh n t  h p phím Ctrl + Gấ ổ ợ c. Nh n F5ấ
b. Nh n t  h p phím Alt + Gấ ổ ợ d. Câu a và c đ u đúngề

12. Đ  ch n ho c di chuy n đ n m t sheet trên b ng tính, thao tác t ng đ ng click chu t tên sheetể ọ ặ ể ế ộ ả ươ ươ ộ  
là
a. Nh n phím TABấ c. Nh n t  h p phím Ctrl + PgUp ho c Ctrl + PgDnấ ổ ợ ặ
b. Nh n t  h p phím Alt + PgUp ho c Alt + PgDnấ ổ ợ ặ d. Câu a và b đ u đúngề

13. Thay đ i s  Sheet trong t p tin s  có hi u l cổ ố ậ ẽ ệ ự
a. V i t t c  các t p tin Excel.ớ ấ ả ậ c. Ch  v i t p tin đang mỉ ớ ậ ở
b. K  t  lúc thay đ i tr  điể ừ ổ ở d. V i các c a s  t p tin đang mớ ử ổ ậ ở

14. Sheet đ c chèn thêm có v  tríượ ị
a.  trên cùng t t c  các SheetỞ ấ ả c.  ngay phía tr c Sheet hi n hànhỞ ướ ệ
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b.  sau cu i t t c  các SheetỞ ố ấ ả d.  ngay phía sau Sheet hi n hànhỞ ệ

15. Mu n xóa Sheet, thao tác th c hi n là  ch n Sheet đó r iố ự ệ ọ ồ
a. Ch n Edit > Delete Sheetọ b. Nh n t  h p phím Alt + E, Lấ ổ ợ
c. Nh p chu t ph i trên tên Sheet ch n Deleteấ ộ ả ọ d. T t c  các câu đ u đúngấ ả ề

16. Phát bi u nào sau đây SAI:ể
a. Có th  sao chép ho c di chuy n các Sheet cùng m t lúc v i đi u ki n b n ph i nhóm ch n chúngể ặ ể ộ ớ ề ệ ạ ả ọ
b. Tên Sheet m i chèn vào là th  t  k  ti p c a s  Sheet trong t p tinớ ứ ự ế ế ủ ố ậ
c. Tên c a Sheet m iđ c sao chép là tên b n chính kèm theo ký hi u (i), i là ch  s  th  t  b n saoủ ớ ượ ả ệ ỉ ố ứ ự ả
d. Ch  có th  sao chép ho c di chuy n các Sheet trong cùng m t t p tin v i nhau mà thôiỉ ể ặ ể ộ ậ ớ

17. Đ  cài đ t ch  đ  n cho Sheet, ta ch n Sheet r iể ặ ế ộ ẩ ọ ồ
a. Ch n Format > Sheet > Hideọ c. Ch n Window > Hideọ
b. Ch n Data > Group and Outline > Hide Detailọ d. T t c  các câu đ u đúngấ ả ề

18. Trong Excel đ  m  t p tin trên đĩa ta dùng:ể ở ậ
a. Ch n File > Openọ b. T  h p phím Ctrl + Oổ ợ c. T  h p phím Ctrl + Nổ ợ d. Câu a và b đ u đúngề

19. Trong Excel đ  l u m t t p tin trên đĩa ta dùng:ể ư ộ ậ
a. T  h p phím Ctrl + Sổ ợ b. T  h p phím Alt + Shift + Sổ ợ
c. T  h p phím Alt + Sổ ợ d. T t c  các câu đ u saiấ ả ề

20. Nh n F12 đấ ể
a. Th c hi n câu l nh Openự ệ ệ b. Th c hi n câu l nh Closeự ệ ệ
b. Th c hi n câu l nh Save Asự ệ ệ d. Th c hi n câu l nh Printự ệ ệ

21. Mu n l u m t t p tin vào đĩa v i tên khác, ta có th  ch n:ố ư ộ ậ ớ ể ọ
a. Ch n File > Save, ch n t p tin c n l u, OKọ ọ ậ ầ ư b. Ctrl + S
b. Ch n File > Save As, gõ vào tên t p tin, OKọ ậ d. C  3 cách trên đ u đ cả ề ượ

22. Ch n câu phát bi u đúng nh tọ ể ấ
a. Ch  đ  l u t  đ ng ch  th c hi n vi c l u t  đ ng cho t p tin đang ho t đ ngế ộ ư ự ộ ỉ ự ệ ệ ư ự ộ ậ ạ ộ
b. Ch  đ  l u t  đ ng th c hi n vi c l u t  đ ng cho t t c  các t p tin đang mế ộ ư ự ộ ự ệ ệ ư ự ộ ấ ả ậ ở
c. Ch  đ  l u t  đ ng th c hi n vi c l u t  đ ng 10 phút m t l nế ộ ư ự ộ ự ệ ệ ư ự ộ ộ ầ
d. Ch  đ  l u t  đ ng th c hi n theo nh ng tùy ch n mà ng i dùng đã xác l pế ộ ư ự ộ ự ệ ữ ọ ườ ậ

23. Trong Excel đ  đóng m t t p tin, th c hi n thao tác:ể ộ ậ ự ệ
a. n T  h p phím Alt + F,  gõ phím CẤ ổ ợ c.  n T  h p phím Ctrl + WẤ ổ ợ
b. Ch n File > Closeọ d. c  3 Câu a, b và c đ u đúngả ề

24. T  h p phím Ctrl +F4 t ng đ ng v i câu l nh:ổ ợ ươ ươ ớ ệ
a. Đóng t p tin hi n hànhậ ệ c. Thoát kh i Excelỏ
b. M  t p tin m iở ậ ớ d. Tìm ki m t p tinế ậ

25. Theo m c đ nh ký t  d ng chu i khi nh p vào ô đ c:ặ ị ự ạ ỗ ậ ượ
a. Canh ph i trong ôả c. Canh đ u 2 bênề
b. Canh trái trong ô d. Canh gi a trong ôữ

26. Theo m c đ nh ký t  d ng s  khi nh p vào ô đ c:ặ ị ự ạ ố ậ ượ
a. Canh ph i trong ôả c. Canh đ u 2 bênề
b. Canh trái trong ô d. Canh gi a trong ôữ

27. Trong quá trình ch n kh i ô (vùng) không liên ti p nhau, ta nh n và giọ ố ế ấ ữ
a. Phím Shift c. Phím Ctrl
b. T  h p phím Alt + Shiftổ ợ d. T  h p phím Alt + Ctrlổ ợ

28. Đ  ch n tr n m t c t trong trang b ng tính, ta di chuy n đ n c t đó r iể ọ ọ ộ ộ ả ể ế ộ ồ
a. Nh n t  h p phím Ctrl + Spacebarấ ổ ợ c. Nh n t  h p phím Page Downấ ổ ợ
b. Nh n t  h p phím Ctrl + Aấ ổ ợ d. Nh n t  h p phím Alt + Page Downấ ổ ợ

29. Đ  ch n tr n m t hàng trong trang b ng tính, ta di chuy n đ n hàng đó r iể ọ ọ ộ ả ể ế ồ
a. Nh n t  h p phím Ctrl + Spacebarấ ổ ợ c. Nh n t  h p phím Shift + Spacebarấ ổ ợ
b Nh n t  h p phím Ctrl + Page Upấ ổ ợ d. Nh n t  h p phím Ctrl + Page Downấ ổ ợ

30. Đ  ch n toàn b  trang b ng tính, phát bi u nào sau đây đúng ể ọ ộ ả ể
Câu A: Nh n t  h p phím Ctrl + A.ấ ổ ợ
Câu B: tr  chu t vào ô giao c a thanh tiêu đ  d c và thanh tiêu đ  ngang r i nh p trái chu t.ỏ ộ ủ ề ọ ề ồ ấ ộ
a. Câu A đúng, câu B saic. câu A đúng , câu B sai
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b. Câu A và câu B đ u saiề d. Câu A và câu B đ u đúngề
31. Ch n câu phát bi u đúng nh t:ọ ể ấ

a. B c nh y khi đi n d  li u có n i dung tăng/ gi m vào ph m vi đã ch n luôn luôn là 1ướ ả ề ữ ệ ộ ả ạ ọ
b. B c nh y khi đi n d  li u có n i dung tăng/ gi m ch  th c hi n theo chi u t  trên xu ng d iướ ả ề ữ ệ ộ ả ỉ ự ệ ề ừ ố ướ
c. B c nh y khi đi n d  li u có n i dung tăng/ gi m vào ph m vi đã ch n ta s  d ng l nh Seriesướ ả ề ữ ệ ộ ả ạ ọ ử ụ ệ
d. B c nh y khi đi n d  li u có n i dung tăng/ gi m vào ph m vi đã ch n ta s  d ng l nh Fillướ ả ề ữ ệ ộ ả ạ ọ ử ụ ệ

32. Trong Excel, có th  m  nhi u t p tin b ng tính, đ  làm vi c v i m t t p tin đã m  ta ch n:ể ở ề ậ ả ể ệ ớ ộ ậ ở ọ
a. Window, ch n t p tin…ọ ậ b. Help, ch n t p tin…ọ ậ
c. Tools, ch n t p tin…ọ ậ d. Edit, ch n tâp tin…ọ

33. Đ  thay đ i đ n v  đoể ổ ơ ị
a. Ch n Toools > Optionọ b. Ch n Format > Paragraghọ
c. Ch n File > Page Setupọ d. Không có ch  đ  thay đ i đ n vế ộ ổ ơ ị

34. Mu n xem thông tin t ng quát t p tin đang so n th oố ổ ậ ạ ả
a. Ch n File > Summary Infoọ b. Ch n View > Full Screenọ
c. Ch n Tools > Gerenalọ d. T t c  các câu đ u đúngấ ả ề

35. Trong Excel mu n s  d ng h p tho i Find đ  tìm ki m ta:ố ử ụ ộ ạ ể ế
a. Nh n t  h p phím Ctrl + Fấ ổ ợ b. Ch n Edit > Findọ
c. C  2 câu đ u đúngả ề d. C  2 câu đ u saiả ề

36. Trong Excel mu n s  d ng h p tho i Replace đ  thay th  ta:ố ử ụ ộ ạ ể ế
a. Nh n t  h p phím Ctrl + Hấ ổ ợ b. Nh n t  h p phím Ctrl + F, nh p Replaceấ ổ ợ ấ
c. Ch n Edit > Replaceọ d. T t c  các câu đ u đúngấ ả ề

37. Ch n câu phát bi u đúng nh tọ ể ấ
a. Trong Excel c t đ c chèn vào bên trái c t hi n hànhộ ượ ộ ệ
b. Trong Excel hàng đ c chèn vào bên d i hàng hi n hànhượ ướ ệ
c. Trong Excel không có ch  đ  chèn thêm c t vào b ng tínhế ộ ộ ả
d. Trong Excel không có ch  đ  chèn thêm hàng vào b ng tínhế ộ ả

38. Trong Excel đ  chèn m t c t vào trong b ng tính, ch n 1 ô b t kì trong c t c n thêm vào r iể ộ ộ ả ọ ấ ộ ầ ồ
a. ch n Column > Insertọ b Ch n Format > Cellsọ
c. Ch n Format > Columnọ d. Ch n Insert > Columnọ

39. Trong Excel đ  chèn m t hàng vào trong b ng tính, ta ch n 1 ô b t kì trong hàngể ộ ả ọ ấ  c n ầ thêm r i:ồ
a. Ch n Format > Cellsọ b. Ch n Format > Columnọ
c. Ch n Insert > Rowọ d. Ch n Insert > Columnọ

40. Trong Excel đ  thay đ i chi u cao c a m t hàng trong b ng tính, ta di chuy n ô hi n hành đ nể ổ ề ủ ộ ả ể ệ ế  
hàng c n thay đ i chi u cao r iầ ổ ề ồ
a. Ch n Format > Rows > Heightọ c. Ch n Format > Cells > Numberọ
b. Ch n Insert > Cells, Entire Rowọ d. Ch n Format > Column, Widthọ

41. Hãy ch n câu phát bi u đúng nh t: đ  xóa d  li u trong m t ô ho c vùng trong b ng tính ọ ể ấ ể ữ ệ ộ ặ ả
a. Ch n ô (ho c kh i ô) c n xóa, nh n phím Deleteọ ặ ố ầ ấ
b. Không c n ch n ô (ho c kh i ô), ch  c n nh n phím Deleteầ ọ ặ ố ỉ ầ ấ
c. Ch n ô (ho c kh i ô) c n xóa, nh n phím Insertọ ặ ố ầ ấ
d. Ch n ô (ho c kh i ô) c n xóa, nh n phím b t kỳọ ặ ố ầ ấ ấ

42. Mu n sao chép d  li u c a ô (hoăc kh i ô) trong b ng tính Excel, taố ữ ệ ủ ố ả
a. Ch n ô (ho c kh i ô) c n sao chép và nh n t  h p phím Ctrl + C, sau đó đ a con tr  đ n v  tríọ ặ ố ầ ấ ổ ợ ư ỏ ế ị  

c n sao chép và nh n t  h p phím Ctrl + Vầ ấ ổ ợ
b. Ch n ô (ho c kh i ô) c n sao chép và nh n t  h p phím Ctrl + X, sau đó đ a con tr  đ n v  tríọ ặ ố ầ ấ ổ ợ ư ỏ ế ị  

c n sao chép và nh n t  h p phím Ctrl + Vầ ấ ổ ợ
c. Không c n ch n ô (ho c kh i ô) ch  c n nh n t  h p phím Ctrl + C, sau đó đ a con tr  đ n v  tríầ ọ ặ ố ỉ ầ ấ ổ ợ ư ỏ ế ị  

c n sao chép và nh n t  h p phím Ctrl + Vầ ấ ổ ợ
d. Ch  có cách nh p l i d  li u trong ô (ho c kh i ô) vào v  trí c n thi tỉ ậ ạ ữ ệ ặ ố ị ầ ế

43. Đ  sao chép d  li u c a ô (ho c vùng) trong b ng tính Excel v i nh ng thông s  n đ nh, ể ữ ệ ủ ặ ả ớ ữ ố ấ ị
a. S  d ng thêm h p tho i Paste Special trong menu Edit đ  ch n thông s  n đ nhử ụ ộ ạ ể ọ ố ấ ị
b. S  d ng thêm h p tho i Cell trong menu Format đ  đ nh d ng nh ng thông s  n đ nhử ụ ộ ạ ể ị ạ ữ ố ấ ị

44



H ng d n kĩ năng s  d ng MS Excel 2K3ướ ẫ ử ụ 45 

c. Sao chép d  li u đ n ô (ho c kh i ô) đ n v  trí m i r i s  d ng h p tho i Cell trong menu Format đữ ệ ế ặ ố ế ị ớ ồ ử ụ ộ ạ ể 
đ nh d ngị ạ

d. Có th  th c hi n c  3 cách trên, cách nào cũng đúngể ự ệ ả
44. Mu n di chuy n d  li u c a ô (ho c kh i ô) trong b ng tính Excel taố ể ữ ệ ủ ặ ố ả

a. Ch n ô (ho c kh i ô) c n di chuy n và nh n t  h p phím Ctrl + C, sau đó đ a con tr  đ n v  tríọ ặ ố ầ ể ấ ổ ợ ư ỏ ế ị  
c n sao chép và nh n t  h p phím Ctrl + Vầ ấ ổ ợ

b. `C n ô (ho c kh i ô) c n di chuy n và nh n t  h p phím Ctrl + X, sau đó đ a con tr  đ n v  tríọ ặ ố ầ ể ấ ổ ợ ư ỏ ế ị  
c n sao chép và nh n t  h p phím Ctrl + Vầ ấ ổ ợ

c. C  hai câu a, b đ u đúngả ề
d. C  hai câu a, b đ u saiả ề

45. T  h p phím Ctrl + 1 dùng đ :ổ ợ ể
a. T o kho ng h  hàng đ n cho trang b ng tínhạ ả ở ơ ả c. T o kho ng h  hàng đúp trang b ng tínhạ ả ở ả
b. T o kho ng h  hàng m t r i cho trang b ng tínhạ ả ở ộ ưở ả d. M  h p Format Cellsở ộ

46. Đ  canh l  ph i m t ô (ho c kh i ô) trong Excel ta ch n ô (ho c kh i ô) đó r i ch nể ề ả ộ ặ ố ọ ặ ố ồ ọ
a. Format > Cells > Aligment... c. Ch n Page Setup, Margins, Rightọ
b. Nh n t  h p phím Ctrl+ Rấ ổ ợ d. Nh n t  h p phím Alt + Ctrl + Rấ ổ ợ

47. Đ  canh gi a m t ô (ho c kh i ô) trong Excel ta ch n ô (ho c kh i ô) đó r i ch n:ể ữ ộ ặ ố ọ ặ ố ồ ọ
a. Nh n t  h p phím Ctrl + Eấ ổ ợ
b. Nh n phím Spacebar cho đ n khi nào vào đ n gi a thì thôiấ ế ế ữ
c. Format > Cells > Aligment...
d. T t c  đ u saiấ ả ề

48. Trong Excel mu n b t/ t t ch  đ  in đ m ta có th :ố ậ ắ ế ộ ậ ể
a. Nh n t  h p phím Ctrl + Bấ ổ ợ c. Nh n t  h p phím Alt + Bấ ổ ợ
b. Nh n t  h p phím Ctrl + Shift + Bấ ổ ợ d. C  2 câu a và c đ u đúngả ề

49. Trong Excel mu n b t/ t t ch  đ  in nghiêng ta có th  ch n:ố ậ ắ ế ộ ể ọ
a. Ch n Format > Font, OKọ c. Ctrl + I
b. Nh n t  h p Alt + Iấ ổ ợ d. Nh n t  h p phím Ctrl + Shift + Iấ ổ ợ

50. Trong Excel mu n b t/ t t ch  đ  g ch d i ta có th  ch n:ố ậ ắ ế ộ ạ ướ ể ọ
a. Nh n t  h p Ctrl + Uấ ổ ợ c. Nh n t  h p Alt + Uấ ổ ợ
b. Nh n t  h p phím Ctrl + Shift + Wấ ổ ợ d. Câu a và b đúng

51. Đ  t o n n và màu s c trang trí cho ô (ho c kh i ô) đã ch n, b n ch n ô (ho c kh i ô) c n t oể ạ ề ắ ặ ố ọ ạ ọ ặ ố ầ ạ  
n n và màu trang trí r iề ồ
a. Ch n Format > Cells ch n th  l nh Patternsọ ọ ẻ ệ c. Ch n Format > Cells ch n th  l nh Borderọ ọ ẻ ệ
b. Ch n Format > Cells ch n th  l nh Alignmentọ ọ ẻ ệ d. Ch n Format > Cells ch n th  l nh Protectionọ ọ ẻ ệ

52. Cú pháp Hàm Vlookup(tr  dò, b ng dò, n, cách dò) , phát bi u nào đúng:ị ả ể
a. n là cột bên phải cột chứa mã dò của bảng dò. c. n là  cột đầu tiên của  bảng dò
b. n là cột thứ 2 của  bảng dò  d. Cả a, b, c đều sai.

53. Trong Excel, đ  sao chép giá tr  1 ô hay vùng đ n v  trí khác ( không chép công th c), thao tácể ị ế ị ứ  
th c hi n là:ự ệ
a. ch n ô c n chép, g  CTRL+C, click ch n ô đ n, g  CTRL+Vọ ầ ỏ ọ ế ỏ
b. ch n ô c n chép, ch n Edit > copy, click ch n ô đ n,  ch n Edit > pasteọ ầ ọ ọ ế ọ
c. 2 câu a và b đ u đúngề
d. ch n ô c n chép, ch n Edit > copy, click ch n ô đ n,  ch n Edit > paste special, ch n valueọ ầ ọ ọ ế ọ ọ
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Bài 2  
Tính tóan trong b ng tínhả

a. Đi u ki n tiên quy t:ề ệ ế
 Làm ch  các kĩ năng thao tác c  b n di chuy n con tr  ô trong b ng tínhủ ơ ả ể ỏ ả
 Th c hi n thành th o kĩ năng qu n lí t p tin b ng tính.ự ệ ạ ả ậ ả
 Làm ch  kĩ năng liên quan ô, dòng, c t - các thao tác nh p, xóa, s a, chép,ủ ộ ậ ử  

di chuy n d  li u, đ nh d ng d  li u trên b ng tínhể ữ ệ ị ạ ữ ệ ả

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c khái ni m đ a ch  t ng đ i, tuy tả ả ượ ệ ượ ệ ị ỉ ươ ố ệ  

đ i, h n h p trên b ng tính.ố ỗ ợ ả
 Mô t  đ c quy trình l p công th c và tính tóan cho b ng tính.ả ượ ậ ứ ả
 Mô t  cú pháp và v n d ng đ c các hàm tóan h c c  b n đ  tính tóan l pả ậ ụ ượ ọ ơ ả ể ậ  

b ng tính theo yêu c u.ả ầ

c.  N i dungộ

Đ  tính tóan trong sheet, c n nh p công th c cho ô c a c t c n tính tóan cho dòng đ uể ầ ậ ứ ủ ộ ầ ầ  
tiên, sau đó sao chép công th c này cho các dòng còn l i trong c t đó. Đ  th c hi n vi cứ ạ ộ ể ự ệ ệ  
đó, khi nh p công th c c n nh p đ a ch  ch  không ph i giá tr . ậ ứ ầ ậ ị ỉ ứ ả ị

Excel nh n bi t d  li u nh p vào là công th c khi kí t  đ u tiên c a công th c là  d u =ậ ế ữ ệ ậ ứ ự ầ ủ ứ ấ

1. Các toán t  và đ  u tiên gi a các toán t .ử ộ ư ữ ử
1.1 Các toán t  (phép tính) trong Excel:  +, -, *, /, ^ (l y th a), n i chu i &, ử ủ ừ ố ỗ

Tóan t  so sánh : <, <=, >, >=, <> (khác nhau)ử

1.2  Đ  u tiên gi a các toán t .ộ ư ữ ử
Khi s  d ng các toán t  trong công th c, Excel th c hi n tính toán theo quy lu t t  trái quaử ụ ử ứ ự ệ ậ ừ  
ph i và tính toán v i các toán t  theo ch  đ  u tiên nh  sau:ả ớ ử ế ộ ư ư

D u ngo c () ấ ặ  %   ^ (l y th a) ủ ừ  *, / (nhân chia) +,- (c ng/tr ) ộ ừ  &  =, <, >, >=, <>

Các lo i đ a ch  :ạ ị ỉ
Đ a ch  tuy t đ i (absolute address) : s  b  đi u ch nh khi sao chépị ỉ ệ ố ẽ ị ề ỉ
Đ a ch  t ng đ i (relative address) : không b  đi u ch nh khi sao chép.ị ỉ ươ ố ị ề ỉ
Đ a ch  h n h p (mixed address) : thành ph n nào có d u $ bên trái không b  đi u ch nhị ỉ ỗ ợ ầ ấ ị ề ỉ  
khi sao chép.
Đ a ch  c a 1 Cell là s  hi u t ng ng c a c t hàng.ị ỉ ủ ố ệ ươ ứ ủ ộ
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Ví du  : A1 là đ a ch  t ng đ i. (Cell có ký hi u c t là A và s  hi u hàng là 1)ị ỉ ươ ố ệ ộ ố ệ
$A$1 là đ a ch  tuy t đ i. (c  đ nh c t A và dòng 1)ị ỉ ệ ố ố ị ộ
A$1 là đ a ch  h n h p. (c  đ nh dòng 1)ị ỉ ỗ ợ ố ị
$A1 là đ a ch  h n h p. (c  đ nh c t A)ị ỉ ỗ ợ ố ị ộ

Đ  thay đ i các lo i đ a ch  :ể ổ ạ ị ỉ
A1 →gõ F4→ $A$1 →gõ F4→ A$1 →gõ F4→ $A1 →gõ F4→ A1.

Có 2 cách ghi đ a chị ỉ :
Cách ghi đ a ch  trên là cách th ng dùng nh t. Ngoài ra còn cách ghi đ a ch  theo RmCn,ị ỉ ườ ấ ị ỉ  
cách ghi đ a ch  này ng v i hàng và c t đ u là s  hi u b n ph i vào menu Tools, ch nị ỉ ứ ớ ộ ề ố ệ ạ ả ọ  
Option, ch n General, đánh d u ch n m c R1C1.ọ ấ ọ ụ

1.3 Đ a ch  t ng đ i, tuy t đ i và đ a ch  h n h pị ỉ ươ ố ệ ố ị ỉ ổ ợ
Trong công th c có tham chi u đ n đ a ch  ô hay vùng, các đ a ch  này th ng là đ a chứ ế ế ị ỉ ị ỉ ườ ị ỉ 
t ng đ i. Khi sao chép công th c có đ a ch  t ng đ i, các đ a ch  ô trong công th c c a ôươ ố ứ ị ỉ ươ ố ị ỉ ứ ủ  
đích cũng đ c c p nh t  và thay đ i thành các đ a ch  t ng đ i khác.ượ ậ ậ ổ ị ỉ ươ ố

Ví d :ụ

Công th c t i ô ứ ạ C1 là =A1+B1, khi sao chép xu ng ô C2 thì công th c t i ố ứ ạ C2 là: =A2+B2

Công d ngụ  : S  d ng đ a ch  t ng đ i, ta có th  tính tóan t  đ ng cho nhi u dòng ch  c nử ụ ị ỉ ươ ố ể ự ộ ề ỉ ầ  
nh p công th c cho ô đ u tiên c a dòng đ u tiên c n tình tóan sau đó sao chép công th cậ ứ ầ ủ ầ ầ ứ  
đó cho các dòng còn l i. ạ

Ví d  2ụ : Đ  tính t ng đi m cho l p (cho m i HS), Hãy nh p b ng tính sau và th c hi n nhể ổ ể ớ ỗ ậ ả ự ệ ư 
theo t ng b c g i ý nh  sau: ừ ướ ợ ư
B c1ướ : tính đi m T ng cho HS tên Minh (dòng 3):ể ổ

click ô E3, g  d u =, click B3, g  d u +, click  C3, g  d u +, click D3 r i Enterỏ ấ ỏ ấ ỏ ấ ồ
b c2ướ : Sao chép công th c này cho các dòng còn l i b ng cáchứ ạ ằ

Ta có k t qu  nh  sauế ả ư

47

Excel t  đ ng ự ộ
c p nh t đ a ch  ậ ậ ị ỉ
t ng đ i cho các ươ ố
dòng còn l i và ạ
tính tóan v i đ a ớ ị
ch  m i đã c p ỉ ớ ậ
nh tậ



H ng d n kĩ năng s  d ng MS Excel 2K3ướ ẫ ử ụ 48 

 Hãy th  click chu t vào các ô E4, E5, E6 s  th y công th c đ c Excel c p nh t l nử ộ ẽ ấ ứ ượ ậ ậ ầ  
l t nh  hình trên.ượ ư

 Hãy th  thay đ i giá tr  c a B3 ( s  8 thành s  5) s  th y T ng s  t  đ ng thay đ i.ử ổ ị ủ ố ố ẽ ấ ổ ẽ ự ộ ổ

 N u mu n không thay đ i đ a ch  khi sao chép công th c đ n ô khác thì ph i sế ố ổ ị ỉ ứ ế ả ử 
d ng đ a ch  tuy t đ i b ng cách c  đ nh đ a ch  nh  sau:ụ ị ỉ ệ ố ằ ố ị ị ỉ ư

Ví dụ: ta c n tính ti n VNĐ t ng ng ti n USD: VNĐ= t  giá chuy n đ i * USDầ ề ươ ứ ề ỉ ể ổ

T  giá chuy n đ i : 1 USD= 15550 VNĐ (ô C1)ỉ ể ổ

N u t i B3 ta nh p công th c =C1 * A3 ta s  có k t qu  77500 (đúng). Nh ng khi sao chépế ạ ậ ứ ẽ ế ả ư  
công th c  B3 cho các ô B4, B5, B6 ta s  có k t qu  nh  sauứ ẽ ế ả ư

Công th c t i B3 : =$C$1*A3  v i $C$1 là đ a ch  tuy t đ i nghĩa là khi sao chép công th cứ ạ ớ ị ỉ ệ ố ứ  
B3 cho các ô B4, B5, B6, B7 đ a ch  này s  gi  nguyên. Cách th c hi n:ị ỉ ẽ ữ ự ệ

click B3, g  = r i click C1, g  phím F4 đ  chuy n sang đ a ch  tuy t đ i, g  *, click A3,ỏ ồ ỏ ể ể ị ỉ ệ ố ỏ  
enter ta có ngay k t qu  là 77500 t i ô B3. Ti n hành sao chép cho các ô còn l i c a c tế ả ạ ế ạ ủ ộ  
B3 B7

N u mu n không thay đ i đ a ch  khi sao chép công th c đ n ô khác thì ph i s  d ng đ aế ố ổ ị ỉ ứ ế ả ử ụ ị  
ch  tuy t đ i b ng cách c  đ nh đ a ch  nh   sau:ỉ ệ ố ằ ố ị ị ỉ ư
Ví d  ta có b ng tính nh  sau:ụ ả ư
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B n hãy th  tr  chu t vào các ô C4 và C5 s  th y l n l t công th c nh  sauạ ử ỏ ộ ẽ ấ ầ ượ ứ ư sai

Cách kh c ph cắ ụ : click ch n ô C3, nh p l i =B3* ọ ậ ạ click  C1, g  Phím F4, enterỏ

Ví d : ụ  Hãy nh p công th c  =A2, g  d u *, click ô C1 r i th  g  phím F4  nhi u l n vàậ ứ ỏ ấ ồ ử ỏ ề ầ  
quan sát s  thay đ i đ a ch  C1ự ổ ị ỉ

=A2*C1 A2*$C$1 A2*C$1 A2*$C1
Ghi nhớ :ngay khi click đ a ch  C1, g  phím F4 ch  có tác d ng đ i v i đ a ch  C1.ị ỉ ỏ ỉ ụ ố ớ ị ỉ

Câu h i t  ôn t p ki m tra ki n th c vàỏ ự ậ ể ế ứ
kĩ năng nh p, đ nh d ng, sao chép d  li u, công th cậ ị ạ ữ ệ ứ

1. Trong 1 bảng tính Excel, ô A5 chứa công thức: =A1*$C$1. Vậy $C$1 là
a. địa chỉ tương đối c. địa chỉ tuyệt đối theo dòng
b. địa chỉ tuyệt đối theo cột d. địa chỉ tuyệt đối 

2. Khi tính tóan trên các lọai dữ liệu, Excel sử dụng các tóan tử ( phép tính) như sau:
1.  D u ngo c ()   ấ ặ 2. %  3. ^ (l y th a) ủ ừ   4. *, / (nhân chia) 
5.  +,- (c ng/tr )ộ ừ 6. & 7.  =, <, >, >=, <>

Th  t  u tiên khi Excel tính tóan làứ ự ư
a. 1, 2, 3, 4, 5, 6, 7 b. 1, 3, 2, 4, 5, 6, 7 c. 1, 2, 4, 3, 7, 5, 6 d. 1, 2, 3, 4, 6, 5, 7

3. Trong 1 bảng tính Excel, ô A1, A2, A3 lần lượt chứa số 1, 2, 3.  Công thức tại A4 là =A1&A2 
sẽ cho kết quả là 

a. 12 b. 13 c. 3 d. Excel báo lỗi cú pháp
4. Trong 1 bảng tính Excel, ô A1, A2, A3 lần lượt chứa chữ A, B, C.  Công thức tại A4 là 
=A1+A2 sẽ cho kết quả là 

a. 12 b. 13 c. 3 d. Excel báo lỗi #VALUE
5. Trong 1 bảng tính Excel, ô A1=A,  A2= B và B1=1, B2=2.  Công thức tại A4 là =A1+B1 sẽ 
cho kết quả là 

a. A b. A1 c. 1A d. Excel báo lỗi #VALUE
6. Trong 1 bảng tính Excel, ô A1=A,  A2= B và B1=1, B2=2.  Công thức tại A4 là =A1&B1 sẽ 
cho kết quả là 

a. A b. A1 c. 1A d. Excel báo lỗi #VALUE
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7. Trong 1 bảng tính Excel, ô A1=A,  A2= B và B1=1, B2=2.  Phát biểu nào sau đây đúng về 2 
Công thức (1)=A1&B1 và  công thức (2): A1 + B1

a. cho kết quả như nhau c. cho kết quả khác nhau
b. (1)  gây lỗi, (2) không gây lỗi (kiểu dữ liệu) d. (2) gây lỗi, (1) không gây lỗi (kiểu dữ liệu)

8.  Trong 1 bảng tính Excel, ô A2=3,  A3= 4, B1=2 . Công thức tại B2 là =A2+$B1. Khi sao chép 
công thức này cho ô B3. công thức của ô B3 là 

a. A3+B1 b. A3+$B2 c. A3+$B1 d. Excel báo lỗi #VALUE
9. Trong 1 bảng tính Excel, ô A2=3,  A3= 4, B1=2 . Công thức tại B2 là =A2+$B$1. Khi sao 
chép công thức này cho ô B3. công thức của ô B3 là 

a. A3+B1 b. A3+$B2 c. A3+$B$1 d. A3+B$2
10.Trong 1 bảng tính Excel, ô A2=3,  A3= 4, B1=2 . Công thức tại B2 là =A2+B$1=5. Khi sao 
chép công thức tại B2 cho ô B3. Kết quả ô B3 là 

a. 6 b. 9 c. 7 d. trị khác
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Bài t p 5ậ
Nh p b ng tính  và đ nh d ng nh  m u sau và l u v i tên NHANVIEN.XLS vào th  m c D:\ậ ả ị ạ ư ẫ ư ớ ư ụ

1. Tính L NG = LCB x NGÀY CÔNGƯƠ
H ng d nướ ẫ : Click ô E2, nh p d u=, click C2, g  phím *, click D2, enter r i ti n hành saoậ ấ ỏ ồ ế  
chép công th c cho các ô còn l i = cách click E2, tr  chu t t i góc ph i d i cho đ n khiứ ạ ỏ ộ ạ ả ướ ế  
hi n d u th p đen, click đôi hay click kéo xu ng đ n ô E7ệ ấ ậ ố ế

2. Tính T M NG = 2/3 l ng  ( ph i hi u là L NG x  2/3)Ạ Ứ ươ ả ể ƯƠ

     H ng d nướ ẫ : Click  F2, g  =, click E2, g  **/3 và enter r i sao chép xu ng cho các ô F2:F6ỏ ỏ ồ ố

3. tính CÒN L I = L NG – T M NG Ạ ƯƠ Ạ Ứ

    H ng d nướ ẫ : Click E2, g  d u =, click  E2, g  d u tr  - , click  F2 r i Enter và sao chép cho các ôỏ ấ ỏ ấ ừ ồ  
phía d i t  G3 đ n G6.ướ ừ ế

4. tính T ng các c t NGÀY CÔNG, L NG, T M NG, CÒN L I ổ ộ ƯƠ Ạ Ứ Ạ

H ng d nướ ẫ  : click D8, click nút  SUM 

S  hi n ra =SUM(D2:D7) ẽ ệ

b n g  Enter đ  ch p nh n vùng tính t ng c a Excelạ ỏ ể ấ ậ ổ ủ

5. Đ nh d ng các c t l ng, t m ng, còn l i có 1 s  l  th p phânị ạ ộ ươ ạ ừ ạ ố ẻ ậ
H ng d nướ ẫ  : Tô vùng E2:F7, click nút tăng gi m s  s  l  th p phân trên thanh công cả ố ố ẻ ậ ụ

6. Chèn thêm c t STT bên trái c t H  và tên r i đi n s  th  t  t  đ ng cho c t nàyộ ộ ọ ồ ề ố ứ ự ự ộ ộ
(Xem kĩ năng đi n s  th  t  trang  38)ề ố ứ ự

51



H ng d n kĩ năng s  d ng MS Excel 2K3ướ ẫ ử ụ 52 

Bài t p 6ậ

Hu ng d n :ớ ẫ

1. Tính Thành Ti n USD: Click I5, g  d u =, g  SUM(, click C2 tô vùng kéo qua H2, gề ỏ ấ ỏ ỏ 
d u ngo c ), g  d u *, click B5 và enter. Sao chép công th c này cho các ô I6:I10ấ ặ ỏ ấ ứ

2. Tính Thành Ti n VND: Click J5, g  d u =, click I5 g  d u *, click J2 r i phím F4 (đ  cề ỏ ấ ỏ ấ ồ ể ố 
đ nh đ a ch  J25), và enter. Sao chép công th c này cho các ô J6:J1ị ị ỉ ứ

3. Tính T ng thành ti n: Click ô I10, click nút SUM ổ ề trên thanh công c . Sụ ẽ 

hi n ra  =SUM(I5:I9). G  enter đ  ch p nh n tính t ng. Sao chép công th c ô này quaệ ỏ ể ấ ậ ổ ứ  

bên ph iả

Bài t p 7ậ
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Gi i thi u hàm ớ ệ

kĩ năng s  d ng hàm trong Excelử ụ

1.  Gi i thi u các hàm tóan h c và các hàm tính tóan đ n gi nớ ệ ọ ơ ả
 Đ  h  tr  ng i dùng tính tóan nhanh trên b ng tính, Excel cung c p s n 1 s  công th c,ể ổ ợ ườ ả ấ ẵ ố ứ  
th  t c đ c bi t đ  tính nhanh. Ng i dùng ch  c n nh p tên th  t c kèm 1 vài tham sủ ụ ặ ệ ể ườ ỉ ầ ậ ủ ụ ố 
theo yêu c u thì s  có k t qu  ngay. Th  t c đó g i là hàm. Có nhi u l ai hàm trong Excel,ầ ẽ ế ả ủ ụ ọ ề ọ  
trong giáo trình này các b n s  làm quen 1 s  hàm th ng dùng nh  sauạ ẽ ố ừờ ư
Gi  s  ta có b ng tính sau:ả ử ả

Ví d  Thay vì tính t ng vùng A1:A4 b ng công th c : =A1+ A2 +A3+ A4 khi enter ta đ c 41ụ ổ ằ ứ ượ
Ta có th  s  d ng hàm SUM theo cú pháp sau : =SUM(A1:A4)=41ể ử ụ
D ng t ng quát c a m t hàmạ ổ ủ ộ  :

=Tên hàm(Đ i s  1, Đ i s  2, ..., Đ i s  n)ố ố ố ố ố ố
Tên hàm : s  d ng các tên theo tên g i quy c c a Excel.ử ụ ọ ướ ủ
 Đ i số ố : có th  là tr  s , chu i, đ a ch  ô, tên kh i, công th c, hàm khác...ể ị ố ỗ ị ỉ ố ứ
L u ýư  :

 Hàm ph i đ c b t đ u b i d u =.ả ượ ắ ầ ở ấ

 Tên hàm không phân bi t ch  hoa ch  th ng, không đ c vi t t t.ệ ữ ữ ườ ượ ế ắ

 Đ i s  ph i đ c đ t trong d u ().ố ố ả ượ ặ ấ

 Khi s  d ng các đ i s  làm hàm thì không nh p d u = tr c nó.ử ụ ố ố ậ ấ ướ

 không đ c có kho ng tr ng trong khi s  d ng hàm.ượ ả ắ ử ụ

 Phân cách gi a các đ i  s  th ng là d u ph y “,”  (m c nhiên trong List  Separator c aữ ố ố ườ ấ ẩ ặ ủ  
International là d u ph y và phân cách ph n ngàn, ph n th p phân theo ki u M ).ấ ẩ ầ ầ ậ ể ỹ

B n nh  r ng khi b n thay đ i phân cách ph n ngàn, ph n th p phân theo ki u Pháp thì d u phânạ ớ ằ ạ ổ ầ ầ ậ ể ấ  
cách đ i s  b n ph i s  d ng là d u ch m ph y “;” (m c dù b n không đ nh l i trong h p Listố ố ạ ả ử ụ ấ ấ ẩ ặ ạ ị ạ ộ  
Separator Excel s  t  đ ng chuy n khi b n kh i đ ng Excel. Đ i v i tr ng h p này khi b n vàoẽ ự ộ ể ạ ở ộ ố ớ ườ ợ ạ  
Excel s  g p thông báo d i đây tr c khi vào Excel.ẽ ặ ướ ướ
Đ   d  dàng ti p c n công d ng các hàm, B n hãy nh p b ng tính sau vào sheet1 đ  làmể ễ ế ậ ụ ạ ậ ả ể  
d  li u th  các hàmữ ệ ử
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Bài t p ng d ng hàm INT và hàm MODậ ứ ụ
Ví d  1ụ : khách hàng thuê phòng  khách s n 22 ngày. H i Khách  m y tu n? M y ngàyở ạ ỏ ở ấ ầ ấ  
lẻ
22 ngày t ng đ ng 22/7= 3,1 tu nươ ươ ầ
chính xác là 3 tu n = cách l y ph n nguyên c a phép chia  =INT(22/7)=3ầ ấ ầ ủ
s  ngày thuê khách s ng là s  ngày l  là 1 là ph n d  c a phép chia 22 cho 7ố ạ ố ẻ ầ ư ủ

S  ngày  sau khi tính nh  chuy n v  đ nh d ng general đ  hi n th  s  nguyênố ở ớ ể ề ị ạ ể ể ị ố
(Ch n vùng D2:D7, ch n Format > cells, ch n number, ch n general )ọ ọ ọ ọ
S  ngày l  =ph n d  c a (s  ngày /7)ố ẻ ầ ư ủ ố ở
S  tu n =ph n nguyên(s  ngày /7)ố ầ ở ầ ố ở
S  d ng đ a ch  tuy t đ i cho giá ti n  tu n và giá ti n  ngày =E2*$F$9+F2*$F$10ử ụ ị ỉ ệ ố ề ở ầ ề ở
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Ví d  2: ụ Hãy đi n công th c tính s  két nguyên và s  chai l , thành ti n khi bi t s  chai tiêu thề ứ ố ố ẻ ề ế ố ụ 
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Hãy nh p và làm quen v n d ng hàm MAX, MIN, SUM, Average trong các ví d  sauậ ậ ụ ụ
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ĐÁP ÁN BÀI T P 1 SAU KHI HÒAN THÀNHẬ
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Câu h i t  ki m tra ki n th cỏ ự ể ế ứ
1. Ô E1 ch a công th c =A1+$B$1+C$1. Khi sao chép công th c E1 cho ô E2 thì ô E2 s  ch aứ ứ ứ ẽ ứ  

công th c :ứ
a. =A1+$B$1+C$1 b. =A2+$B$1+C$1 c. =A2+$B$1+D$1 d. =A2+$B$3+D$2

2. Trong b ng tính Excel, đ  làm tròn phép tính trung bình c ng c a 3 ô d  li u A1, A2, A3 v i 1 chả ể ộ ủ ữ ệ ớ ữ 
s  th p phân ta dùng hàm:ố ậ

a. =ROUND((A1+A2+A3)/3,1) b. =ROUND(Average(A1:A3),1)
c. =ROUND((A1+A2+A3),1)/3 d. C  2 câu a và b d u đúngả ề

Gi  s  có b ng tính sauả ử ả
A B C D E F

1 Mã SV Tên SV Tóan Văn ĐTB XL aiọ
2 K99-AV01 Xuân 5 6
3 K99-AV02 H iả 5 5
4 K98-AV11 Thu 7 5
5 K97-TH01 Dũng 8 2
6 K97-TH23 Nam 9 2
7 K98-TH10 Trung 8 2

Câu 1: Bi u th c =INT((C2+D2)/2) cho k t q a: _________________ể ứ ế ủ

Câu 2: Bi u th c =MOD(C4,2) cho k t q a: _____________________ể ứ ế ủ

Câu 3: Công th c tính ĐTB v i toán h  s  2, văn h  s  1 và l y 1 s  l  th p phân là:ứ ớ ệ ố ệ ố ấ ố ẻ ậ
a. Round((C2*2+$D$2) / 3,1) c. Round(average(C2*2+D2) / 3,1)
b. Round(average(C2,C2,D2),1) d. C  3 đ u saiả ề
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Bài 3 
Hàm Logic AND, OR và hàm IF
a. Đi u ki n tiên quy t:ề ệ ế

 Làm ch  các kĩ năng thao tác c  b n di chuy n con tr  ô trong b ng tínhủ ơ ả ể ỏ ả
 Th c hi n thành th o kĩ năng l p hàm tính tóan c b n và sao chép k t quự ệ ạ ậ ơ ả ế ả
 Mô t  ý đ c nghĩa tác d ng và cú pháp c a các hàm Average, Sum, Int, Mod, Roundả ượ ụ ủ  

và v n d ng đ c đ  giái quy t các tòan th c t .ậ ụ ượ ể ế ự ế
 Mô t  đ c m t s  l i th ng g p khi s  d ng các hàm trong Excel đ c bi t hàmả ượ ộ ố ỗ ườ ặ ử ụ ặ ệ  

MOD, Round.

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c ý nghĩa và c  ch  h at đ ng c a hàm logic,ả ả ượ ệ ượ ơ ế ọ ộ ủ  

hàm AND, OR . V n d ng t t hàm IF.ậ ụ ố
 Nêu đ c m t s  l i th ng g p khi s  d ng các hàm logic và hàm IF.ượ ộ ố ỗ ườ ặ ử ụ

c.  N i dungộ

1. Th  nào là hàm logic, bi u th c logic ?ế ể ứ
Hàm logic là hàm tr  v  1 trong 2 giá tr  : TRUE (đúng) ho c FALSE (sai)ả ề ị ặ
Bi u th c  logic là bi u th c g m 2 v  ngăn cách nhau b i tóan t  so sánh ho c hàmể ứ ể ứ ồ ế ở ử ặ  
logic và k t qu  tr  v  là 1 trong 2 giá tr : TRUE (đúng) ho c FALSE (sai)ế ả ả ề ị ặ
Các tóan t  so sánhử

= b ng nhauằ
<> khác nhau

> l n h nớ ơ

>= L n h n ho c b ngớ ơ ặ ằ

< Nh  hônỏ

<= Nh  h n hoăc b ngỏ ơ ằ
Ví d : B n hãy nh p b ng d  li u sauđ  th c t p làm quen các bi u th c logicụ ạ ậ ả ữ ệ ể ự ậ ể ứ

B n hãy th c t p nh p các công th c bên trái đ  ki m đ nh k t qu  là TRUE hay FALSEạ ự ậ ậ ứ ể ể ị ế ả
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HV  th c t p nh p và d  đóan k t qu  c a các bi u th c logic sauự ậ ậ ự ế ả ủ ể ứ
=MOD(A1,C3)=MIN(C1:C3)
=SUM(A2:C2)=SUM(C2:C3)
=A1>=A2

B n hãy th c t p nh p l i các bi u th c có hàm AND sau đ  ki m đ nh k t qu  TRUE hayạ ự ậ ậ ạ ể ứ ể ể ị ế ả  
FALSE (làm quen làm AND ( và)

B n hãy th c t p nh p l i các bi u th c có hàm OR sau đ  ki m đ nh k t qu  TRUE hayạ ự ậ ậ ạ ể ứ ể ể ị ế ả  
FALSE (làm quen làm OR( ho c)ặ
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Ví d  1: B n hãy nh p b ng tính sau và s  d ng hàm IF đ  gi i quy t bài tóan x p l aiụ ạ ậ ả ử ụ ể ả ế ế ọ
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Ví d  4:ụ  S  d ng hàm IF k t h p hàm ANDử ụ ế ợ

Ví d  5ụ : S  d ng hàm IF k t h p hàm AND và ORử ụ ế ợ
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Tìm hi u hàm RANKể
Công d ng : x p h ng 1 giá tr  so sánh v i 1 vùng giá tr  ụ ế ạ ị ớ ị

Cú pháp : =RANK(tri x p h ng, vùng so sánh, cách x p) ế ạ ế

Cách x p=0 hoăc không ghi trong công th c: giá tr  l n x p nh  nh t ví d  x p h ng HS,ế ứ ị ớ ế ỏ ấ ụ ế ạ  
Sv trong h c t p: đi m cao nh t h ng th p nh t ( h ng 1)ọ ậ ể ấ ạ ấ ấ ạ

Cách x p =1: th ng dùng trong x p h ng th  thao (đua xe đ p): giá tr  nh  nh t, h ngế ườ ế ạ ể ạ ị ỏ ấ ạ  
nh  nh t ( th i gian v  đích nho3 nh tỏ ấ ờ ề ấ  h ng 1)ạ

Ví d  6:ụ  công th c t i D2 nh  hình minh h aứ ạ ư ọ

Ví d  7:ụ  S  d ng hàm RANK v i cách x p h ng trong th  thaoử ụ ớ ế ạ ể
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BÀI T P 1Ậ

1. D a vào c t ch c v , tính ph  c p ch c v  (PCCV) NH  SAU :ự ộ ứ ụ ụ ấ ứ ụ Ư
Giám đ c (GĐ) : 200000 , Phó Giám đ c (PGĐ) : 150000,  tr ng phòng (TP) : 100000ố ố ưở
phó phòng (PP) : 70000
2. c t Th ng:ộ ưở  Th ng 50000 cho ng i có ngày công t  30 tr  lên, th ng 30000 choưở ườ ừ ở ưở  

ng i có 28<=Ngày công <30ườ
3. c t Th ng 8/3:ộ ưở  Th ng cho n  công nhân 50000 nhând p l  8/3ưỞ ữ ị ễ
4. C t T M NG: T m ng = 80% L ng cho CB-CNV n , 50% cho nhân viên namộ Ạ Ứ ạ ứ ươ ữ

BÀI T P 2Ậ
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BÀIT P 3:Ậ
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Bài 5  
Hàm đ m và hàm th i gianế ờ
a. Đi u ki n tiên quy t:ề ệ ế

Làm ch  các kĩ năng s  d ng hàm IF, And, OR và cac hàm tóan h c c  b nủ ử ụ ọ ơ ả

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c ý nghĩa và c  ch  h at đ ng c a hàmả ả ượ ệ ượ ơ ế ọ ộ ủ  

Count, Counta, CountIF
 Nêu đ c m t s  l i th ng g p khi s  d ng các hàm th ng kê, đ m.ượ ộ ố ỗ ườ ặ ử ụ ố ế

c.  N i dungộ

1. HÀM Đ MẾ

Hãy m  file  ham thongke+dem.xls trong D: đ  rèn luy n kĩ năng. N u không tìm th y b nở ể ệ ế ấ ạ  
hãy nh p b ng tính sau:ậ ả
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B n hãy nh p b ng tính sau và th c hi n th ng kê theo yêu c uạ ậ ả ự ệ ố ấ
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2. Hàm th i gianờ
B n hãy nh p b ng tính sau và nh p công th c tínhc t Ngày,Tháng, Năm,Tu i,ạ ậ ả ậ ứ ộ ổ  
Th  trong b ng r i sao chép cho các dòng phía d iứ ả ồ ướ
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Câu h i ôn t pỏ ậ
A B C D E F

1 Mã SV Tên SV toán văn ĐTB XL
2 K99-AV01 Xuân 5 6
3 K99-AV02 Hạ 5 5
4 K98-AV11 Thu 7 5
5 K97-TH01 Đông 8 2
6 K97-TH23 Nam 9 2
7 K98-TH10 Trung 8 2

Câu 1:  Bi u th c =COUNT(A1:A7) cho k t q a:ể ứ ế ủ ___________________________________

Câu 2: Bi u th c =NOT(OR(C2<5,C2>5)) cho k t q a:ể ứ ế ủ ___________________

Câu 3: Bi u th c =NOT(AND(C2<=D2,C2>5)) cho k t q a:ể ứ ế ủ _______________________

Câu 4: Công th c đ m s  l ng sinh viên: ứ ế ố ượ ___________________________________
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Bài 5  
Hàm X  lí chu iữ ỗ
a. Đi u ki n tiên quy t:ề ệ ế

Làm ch  các kĩ năng v n d ng các hàm IF, And, OR, Count, Counta, CountIFủ ậ ụ

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c ý nghĩa và c  ch  h at đ ng c a hàmả ả ượ ệ ượ ơ ế ọ ộ ủ  

LEFT, RIGHT, MID, VALUE, LEN, Proper, Upper, Lower
 Nêu đ c m t s  l i th ng g p khi s  d ng các hàm v  chu i.ượ ộ ố ỗ ườ ặ ử ụ ề ỗ

c.  N i dungộ
Hàm chu i là hàm x  lí v i d  li u là ki u chu i  ho c s  và tr  ra k t qu  là 1 chu i. Ta cóỗ ữ ớ ữ ệ ể ỗ ặ ố ả ế ả ỗ  
m t s  hàm x  lí chu i nh  sau. Đ  d  dàng ti p c n v n đ , B n hãy nh p b ng d  li uộ ố ữ ỗ ư ể ễ ế ậ ấ ề ạ ậ ả ữ ệ  
minh h a sau ọ

B n hãy nh p l i các công th c d i đây đ  ki m đ nh k t qu  và làm quen hàmạ ậ ạ ứ ướ ể ể ị ế ả
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Th c t p rèn luy n v n d ng hàm rightự ậ ệ ậ ụ
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Ví d :ụ
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Bài t p áp d ng hàm chu i, IF, COUNT, COUNTA, COUNTIF, SUMIFậ ụ ỗ
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Đáp án : Câu 1: =IF(Left(A4)=”B”,90%,1)*D4*E4
Câu 2: =IF(C4=”MHG”,5%*F4, IF(C4=”MHS”,8%*F4, 10%*F4)

Đáp án: câu 1: =LEFT(A4,3) CÂU 2:  MID(A4,4,3)
CÂU 3:  ROUND((E4*2+F2)/3,1)
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G i ýợ : Dùng hàm LEFT đ  th c hi n Câu 1, câu 2, c u 3ể ự ệ ẩ
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Câu h i ôn t pỏ ậ
Gi  s  có b ng tính sauả ử ả

Câu 1: Công th c =ứ MID(RIGHT(B5,4),3,2) cho k t qu  :ế ả
a. 90 b. 31 c. 03 d. C  a, b, c đ u saiả ề

câu 2: Công th c =IF(AND(F3>=6,G3>=5, H3 >=5),"Đ u","R t") cho k t qu :ứ ậ ớ ế ả
a. Đ uậ b. R tớ c. #N/A d. 5

câu 3: Công th c =LEFT(LEFT(B2),3)cho k t qu  :ứ ế ả
a. 01 b. K c. 1 d. Excel báo l iỗ   

Câu 4: Đ  l y ra đ c s  3 (giá tr  s )  ô B4 ta dùng công th c:ể ấ ượ ố ị ố ở ứ
a. =VALUE(RIGHT(B4,3)) c. =VALUE(MID(B4,4,2))
b. =VALUE(MID(B4,3,3)) d. C  a, b, c đ u đúng.ả ề

Câu 5: Công th c =COUNTA(A2:B6) cho k t qu  :ứ ế ả
a. 10 b. 4 c. 0 d. 0

Câu 6: Công th c = MONTH(E5)=9  cho k t qu  :ứ ế ả
a. False b. True c. #N/A d. Giá tr  khácị

Câu 7: Trong m t b ng tính c a Excel, hàm Rank dùng độ ả ủ ể
a. X p h ngế ạ b. Tính trung bình c. Tính t ngổ d. Tính giá tr  l n nh tị ớ ấ

Câu 8:Trong Excel, cú pháp hàm RANK nh  sau (v i n=0,1)ư ớ
a. =RANK(Number, List , Order) b. =RANK(Đ a ch  ô, Vùng, n)ị ỉ
c. =RANK(Number, List) d. C  câu a và b đ u đúngả ề

Câu 9: Trong Excel đ  l y n ký t  bên trái c a m t chu i m ta dùng hàm:ể ấ ự ủ ộ ỗ
a. Left(n,m) b. Right(m,n) c. Left(m,n) d. Right(n,m)

Câu 10: Trong m t b ng tính Excel, ô C5 ch a chu i "TRAN" và ô D5 ch a chu i " BAO",ộ ả ứ ỗ ứ ỗ  
đ  ô E5 có k t qu  là "TRAN BAO" (có 1 kho ng tr ng  gi a) ta nh p công th c:ể ế ả ả ắ ở ữ ậ ứ

a. =A5+" "+B5 b. =A5+B5 c. =A5&" "&B5 d. =A5&B5

Câu 11: Trong m t b ng tính Excel, t i ô D5 có ch a chu i "TR N CHÂU",ộ ả ạ ứ ỗ Ầ  
hàm=lower(D5) cho giá tr  sau:ị

a. Tr n Châuầ b. tr n châuầ c. TR N châuẦ d. Báo l i ERRORỗ

Câu 12: Trong b ng tính Excel, t o ô E5 có ch a chu i "Nguy n th  Giàu" (s  d ng font 2ả ạ ứ ỗ ễ ị ử ụ  
byte), hàm=Len(E5) cho giá tr  sau:ị

a. 13 b. 15 c. 17 d. C  3 câu đ u saiả ề
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Bài 6 
Hàm dò tìm VLOOKUP, HLOOKUP

a. Đi u ki n tiên quy t:ề ệ ế
Làm ch  các kĩ năng v n d ng các hàm IF, And, OR, Count, Counta, CountIF, hàm chu iủ ậ ụ ỗ

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c ý nghĩa và c  ch  h at đ ng c a hàmả ả ượ ệ ượ ơ ế ọ ộ ủ  

Vlookup Hlookup, chính xác và không chính xác
 Nêu đ c m t s  l i th ng g p khi s  d ng các hàm v  do tìm.ượ ộ ố ỗ ườ ặ ử ụ ề

c.  N i dungộ

Đ  d  ti p c n hàm dò tìm, gi  s  ta có b ng d  li u sauể ễ ế ậ ả ử ả ữ ệ

Hàm VLOOKUP dò tìm c t nh y qua c t l y giá trộ ả ộ ấ ị
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Đ  dó tìm l y s  đi n th ai c a 1 ng i có mã NV =”A001” trong b ng tình ta nh p côngể ấ ố ệ ọ ủ ườ ả ậ  
th c nh  sau : =VLOOKUP(A001,$F$2:$I$4,3,0)ứ ư
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Bài t p rèn luy n hàm VLOOKUP và HLOOKUPậ ệ
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ÔN T P T  KI M TRAẬ Ự Ể

Đ  1ề
Hãy tham kh o b ng sau đ  làm nh ng câu ti p theoả ả ể ữ ế

A B C D E F G H I J
1 STT Mã HS H  ọ Tên Ng Sinh Toán Văn NN Xlo iạ Th ngưở

2 1 L8001 Lê Dũng 13/08/03 5 5.5 6 TB 0

3 2 L8006 Tr nầ Hai 29/08/03 7 6 7 Khá 75000

4 3 L8003 H  Thiồ Bình 06/03/03 4.5 8 8 Khá 75000

5 4 L8031 Tô Chính 17/01/03 7 9 5 Khá 75000

6 5 L8022 Vũ Văn Nam 22/11/03 10 8.5 8 Gi iỏ 200000
1. L nh LEFT(LEFT(B2,2),1) cho ta :ệ

a. 1 b. L c. 8 d. 0
2. Đ  l y ra giá tr  s  80  ô B3 ta dùng công th c:ể ấ ị ố ở ứ

a. = RIGHT(LEFT(B3,3),2) b. = VALUE(MID(B3,2,2))
c. = VALUE(MID(B3,3)) d. C  a, b, c đ u đúng.ả ề

3. Công th c = MONTH(E5) cho ta :ứ
a. 17 b. 03 c. 1 d.D2

4. Công th c =IF(YEAR(E4)=03, 3, 2003) cho ta:ứ
a. 06/03/03 b. Không tính đ cượ c. 3 d. 2003

5. Công th c =MATCH("NN",C1:J1,0) cho ta:ứ
a. #N/A b. 4 c. 5 d. 6

6. Công th c =COUNTIF(F2:F6,"7") cho ta :ứ
a. 4 b. 1 c. 2 d. 0

7. Công th c =VLOOKUP(“L8003”,B2:F6,5,0) cho ta:ứ
a. 4.5 b. 7 c. 06/03/03 d. 8

8. Công th c =HLOOKUP(6, F2:H6, 4, 0) cho ta:ứ
a. 7 b. 8 c. 6 d. 5

9. Công th c =IF(AND(F2>=5,G2>=5), “Đ u”, “R t”) cho k t qu :ứ ậ ớ ế ả
a. Đ uậ b. R tớ c. #N/A d. 5

Đ  2ề
Hãy tham kh o b ng sau đ  làm nh ng câu ti p theoả ả ể ữ ế

A B C D E F G

1 MANV H  TÊN NVỌ NGÀY TUY N D NGỂ Ụ Đ N VƠ Ị L NGƯƠ PH  C PỤ Ấ THUẾ

2 TV01 Lê Văn An 10/12/79 Tài vụ 100 50 X

3 TV12 H  Th  H ngồ ị ồ 15/03/87 Tài vụ 120 40 X

4 KT23 Hà Văn 12/03/90 K  thu tỹ ậ 150 60 X

5 KT58 Lý Bá 25/11/97 K  thu tỹ ậ 80 15

6 TV79 Nguy n Namễ 07/03/99 Tài vụ 60 20

1. L nh = LEFT(RIGHT(A2,3),1) cho k t q a :ệ ế ủ
a. TV b. T c. V d.1

2. L nh = IF(WEEKDAY(C2) = 10,4,10) cho k t q a :ệ ế ủ
a. 4 b. 10 c. 1979 d.T t c  a,b,c đ u saiấ ả ề

3. L nh = COUNTIF(D2:D6,"Tài v ") cho k t q a :ệ ụ ế ủ
a. 0 b.1 c.3 d. T t c  a,b,c đ u sai ấ ả ề

4. L nh = COUNT(A2:A6) cho k t q a :ệ ế ủ
a. L nh saiệ b. 0 c.5 d.6

5. L nh = YEAR(C2) cho k t q a :ệ ế ủ
a. 79 b. 1979 c. 10/12/79 d.L nh saiệ
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6. L nh =SUMIF (D2:D6,”k  thu t”, E2:E6) cho k t q a :ệ ỹ ậ ế ủ
a. 0 b.2 c. 230 d. T t c  a,b,c đ u saiấ ả ề

7. L nh = Vlookup (“TV01”, A2:G6, 4, 0) cho k t q a :ệ ế ủ
a. “Lê Văn An” b. “Tài v ”ụ  c. 100 d. T t c  a,b,c đ u saiấ ả ề

8. L nh = Hlookup (“TV01”, A2:G6, 4, 0) cho k t q a :ệ ế ủ
a. “KT58” b. “Tài v ”ụ c. 100 d. T t c  a,b,c đ uấ ả ề  

sai
9. L nh = MATCH("TV01",A2:A6,0 ) cho k t qu  :ệ ế ả

a. “TV79” b. 0 c.1 d. T t c  a,b,c đ u saiấ ả ề
10. L nh = AND (A2 = “TV01”, NOT (E2 > = 100) ) cho k t q a :ệ ế ủ

a. True b. False c. “TV01100” d. T t c  a,b,c đ u saiấ ả ề
11. L nh = OR (AND (1 > = 1, NOT (A2 = “TV01”)) , COUNTA ( G1:G6 = 6)) ệ

a. True b. False c. “TV01” d. T t c  a,b,c đ u saiấ ả ề
12. L nh RANK (F2, F2:F6) cho k t q a :ệ ế ủ

a. 185 b. 135 c. 2 d. T t c  a,b,c đ u saiấ ả ề

Đ  3ề
Hãy tham kh o b ng sau đ  làm nh ng câu ti p theoả ả ể ữ ế

13. Công th c =ROUND(F2*G2+H2/2,0) cho k t qu  là. ứ ế ả
a. 26 b. 27 c. 14 d. 26.5

14. Công th c =ROUND(AVERAGE(A2:B5),0) cho K t qu  làứ ế ả
a. 3 b. 2.5 c. 2 d. Excel báo l iỗ

15. Công th c =LEFT(MID(B2,2,3),1) cho k t qu  ta :ứ ế ả
a. 0 b. 2 c. A d. 1

16. L nh =LEFT(RIGHT(B2,3),1)cho k t qu  là:ệ ế ả
a. “2” b. 2 c. 1 d. “1”

17. L nh =COUNTIF(J2:J7,KHÁ) cho k t qu  là :ệ ế ả
a. 1 b. 3 c. 0 d. Excel báo l iỗ

18. L nh =COUNT(A2:B7) cho k t qu  là :ệ ế ả
a. 6 b. 12 c. 0 d. Excel báo l i ỗ

19. L nh =COUNTA(A2:B7) cho k t qu  là:ệ ế ả
a. 6 b. 12 c. 6 d. Excel báo l iỗ

20. L nh =VLOOKUP(10,F2:H7,3) cho k t qu  là :ệ ế ả
a. 9.5 b. 9 c. 8 d. Excel báo l iỗ

21. L nh =COUNTIF(F2:I7,>9) cho k t qu  là:ệ ế ả
a. 2 b. 3 c. 4 d. Excel báo l iỗ

22. L nh =HLOOKUP(B2,B2:D7,3) cho k t qu  là :ệ ế ả
a. B102 b. HOA c. GIANG d. Excel báo l iỗ
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Đ  4ề
Haõy tham khaûo baûng sau ñeå laøm nhöõng caâu tieáâp theo

A B C D E F G
1 Mã Hàng Tên hàng Ngày nh pậ Kích th cướ Đ n giáơ S  l ngố ượ Thành ti nề

2 TV15 Tivi 15/01/04 15” 100 10 1000

3 TV17 Tivi 15/01/04 17” 120 5 600

4 TV21 Tivi 17/01/04 21” 160 3 480

5 MT15 Máy tính 21/02/04 15” 200 12 2400

6 MT17 Máy tính 12/03/04 17” 250 4 1000

1. L nh = RIGHT(LEFT(A2,2),1) cho k t q a :ệ ế ủ
a. “V” b. “T” c. “TV” d. T t c  a,b,c đ u saiấ ả ề

2. L nh = MID(A2,3,1) cho k t qu :ệ ế ả
a. “TV1” b. “V1” c. “1” d.”15”

3. L nh = COUNTIF(B2:B6,”Tivi") cho k t q a :ệ ế ủ
a. TRUE b.FALSE c. 3 d. 5

4. L nh = COUNT(A1:A6) cho ta :ệ
a. 0 b. 1 c. 6 d. Sai, Thông báo l iỗ

5. L nh = YEAR(C2) cho k t q a :ệ ế ủ
a. 15/01/04 b. 04 c. 2004 d. Sai, thông báo l iỗ

6. L nh = SQRT(E2) + MOD(F2,3) cho k t q a :ệ ế ủ
a. 11 b.13 c. 101 d. 103

7. L nh =IF (INT(F3/ 3) = 1, 1, 2) cho k t q a :ệ ế ủ
a. 0 b.1 c. 2 d. T t c  a,b,c đ u saiấ ả ề

8. L nh = MATCH( “TV15”,A1:A6,0 ) > = RANK( G2,G2:G6) cho k t qu  :ệ ế ả
a. 1 b. 2 c.TRUE d. FALSE

9. VLookup(A2, A2:G6,5,0) cho k t quế ả
a. “MT15” b. 100 c. 10 d. T t c  a,b,c đ u saiấ ả ề

10. = IF (MIN(E2:E6) < SUMIF(B2:B6,”TIVI”,G2:G6), 1, 0) Cho k t qu :ế ả
a. True b. False c.1 d. 0

11. AND(ABS(E2) = 100, NOT(OR (D2 = D3, Average(E2:E6) = 100)))
a. 1 b. 2 c. TRUE d. FLASE

12. L nh = Index (A1:G6,4,5) cho k t q a:ệ ế ủ
a. “TV21” b. “MT15” c. 160 d. T t c  a,b,c đ u saiấ ả ề

Đ  5ề
Cho m t b ng tính nh  sau , trong đó A,B,C,D,E,F,G  là c t và 1,2,3,4,5 là hàng. Gi  s  ngày bán là ngày cóộ ả ư ộ ả ử  
d ng DD/MM/YY  (tr  l i t  câu 26 đ n 40 )ạ ả ờ ừ ế

A B C D E F

1 MA SO TÊN S N PH MẢ Ẩ S  L NGỐ ƯỢ Đ N GIÁƠ THÀNH TI NỀ NGÀY MUA

2 P400 XI MĂNG P400 35 5800 203000 20/06/03

3 P200 XI MĂNG P200 40 4800 192000 25/06/03

4 H021 CÁT 299 300 89700 17/06/03

5 B001 G CH BÔNGẠ 300 2800 840000 30/06/03

1) L nh LEFT(RIGHT(A4,2),3)  cho ta :ệ
a.” 021” b. “21” c. “H02” d.T t c  a,b,c đ u saiấ ả ề

2) L nh HLOOKUP(“5800”,C2:E5,3,0) cho ta :ệ
a. 300 b. 4800 c. 2800 d. T t c  a, b, c đ u saiấ ả ề

3) L nh IF(RIGHT(A4,2)="21",”DUNG”,”SAI”) cho ta :ệ
a. DUNG b. SAI c. “SAI” d.T t c  a,b,c đ u saiấ ả ề
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4) L nh SUMIF(C2:C5,">=50",D2:D5) cho ta :ệ
a. 3100 b. 5200 c. 0 d.T t c  a, b, c đ u sai.ấ ả ề

5) L nh COUNTIF(F2:F5,”17/06/2003”) cho ta :ệ
a. 1 b. 0 c. 2 d. T t c  ab,c đ u sai.ấ ả ề

6) L nh SUM(C4,D5)  cho ta :ệ
 a. 3699 b. 599 c.3099 d. T t c  a,b,c đ u saiấ ả ề

7) L nh VALUE(RIGHT(A4,2)-RIGHT(A3,2)) cho ta :ệ
a. 21 b. “21” c. 2100 d. T t c  a,b,c đ u saiấ ả ề

8) L nh IF(MID(A3,3,2)=”0”,1,0) cho ta :ệ
a. 0 b. 1 c. TRUE d.T t c  a,b,c đ u saiấ ả ề

9) L nh MAX(C2:E5) cho ta :ệ
a. 300 b. 840000 c. 203000 d. T t c  ab,c đ u saiấ ả ề

10) L nh AND(C4<=D5,D3<C5,E2>C5) cho ta :ệ
a. TRUE b. FALSE c. T d. F

11)L nh VLOOKUP(“h021”,A2:F5,4,0) có giá tr   là :ệ ị
a. 299 b. 300 c. 89700 d. T t c  a, b, c đ u sai.ấ ả ề

12)L nh PROPER(B5)  cho ta :ệ
a. G ch bôngạ b. G ch Bôngạ   c. G CH BÔNG     d. T t c  a,b,c đ u saiẠ ấ ả ề

13)L nh OR(E2>C3,D5=E3) cho ta:ệ
a. TRUE b. FALSE c. T d. T t c  a ,b,c đ u sai. ấ ả ề

14)L nh IF(RIGHT(A3,2)=”0”,”DUNG”,”SAI”) cho ta :ệ
a. DUNG b. SAI c. “SAI” d.T t c  a, b, c đ u saiấ ả ề

15)L nh  COUNTIF(C2:D5,”300”) cho ta :ệ
a. Không tính đ cượ b. 1 c.0 d.2

Đ  6ề
Cho m t b ng tính nh  sau , trong đó A,B,C,D,E,F,G,H  là c t và 1,2,3,4,5,6 là hàng .L u ý c t Dộ ả ư ộ ư ộ
ch a các ngày có d ng : dd/mm/yy ( tr  l i t  câu 1 đ n 15 )ứ ạ ả ờ ừ ế

A B C D E F G H

1 HO TEN MA SO NG SINH MON1 MON 2 TB HOC BONG
2 NGUYEN DINH A05 12/07/85 8 7 7.5 100000
3 TRAN CHA

C
B02 09/09/86 5 6 5.5 80000

4 LE THI A04 02/07/86 9 8 8.5 100000
5 PHAM ÂMY B03 23/04/84 10 8 9 123450
6 KY VY A01 07/07/85 9 10 9.5 100000

1. L nh IF(E2="8",10,20) cho ta :ệ
a. 10 b. 20 c. “6” d.T t c  a,b,c đ u saiấ ả ề

2. L nh AND(F3<F4,F4<C6,H6>C2)ệ
a. TRUE b. FALSE c. T d. F

3. L nh IF(RIGHT(C2)=5,4,10) cho ta :ệ
a. 4 b. 10 c. D4 d.T t c  a,b,c đ u saiấ ả ề

4. L nh LEFT(LEFT(A2,1),2) cho ta :ệ
a. N b. G c. E d.A

5. L nh VLOOKUP(B03,C2:H6,4,0) cho ta :ệ
a. #N/A b. 9 c. 8.5 d.8

6. L nh PROPER(A2) cho ta :ệ
a. NGUYEN  b. nguyen c. Nguyen d. T t c  a,b,c đ u saiấ ả ề

7. L nh PRODUCT(E2,E6) cho ta :ệ
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 a. 0 b. 72 c. 32400 d. Không th c hi n đ cự ệ ượ

8. L nh IF(C3="B02",”D”,”S”) cho ta :ệ
a. S b. D c. “D” d.”S”

9. L nh SUMIF(C2:C6,”b0?”,E2:E6 ) cho ta:ệ
a. 15 b. 0 c. 41 d. T t c  a, b, c đ u sai ấ ả ề

10. L nh COUNTIF(E2:G6,"9") cho ta :ệ
a. 4 b. 3 c. 5 d. 0

11. L nh  COUNTIF(D2:D6,"7/7/1985") cho ta :ệ
a. Không tính đ cượ b. 1 c. 0 d. 2

12. L nh SUM(E2:F3) +15  cho ta :ệ
a. 41 b. 29 c. 28 d. T t c  a,b,c đ u saiấ ả ề

13. Ch n 2 ô A6 và B6 r i nh p vào nút công c  Merge and Center s  cho ta:ọ ồ ắ ụ ẽ
a. KYVY b. KY c. VY d. T t c  a, b, c đ u saiấ ả ề

14. L nh ROUND(H5,-3) cho ta:ệ
a.123000 b. 123400 c. 123500 d. T t c  a, b, c đ u sai ấ ả ề

15.  L nh MOD(E6, F6) cho ta:ệ
a. 1 b. 10 c. 9 d. T t c  a, b, c đ u saiấ ả ề
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Bài 7
S p x p và rút trích c  s  d  d  li uắ ế ơ ở ữ ữ ệ

a. Đi u ki n tiên quy t:ề ệ ế
Làm ch  các kĩ năng v n d ng các hàm IF, And, OR, Count, Counta, CountIF, hàm chu iủ ậ ụ ỗ

b. M c tiêuụ
 Gi i thích và mô t  đ c, phân bi t đ c ý nghĩa và c  ch  h at đ ng c a hàmả ả ượ ệ ượ ơ ế ọ ộ ủ  

Vlookup Hlookup, chính xác và không chính xác
 Nêu đ c m t s  l i th ng g p khi s  d ng các hàm v  do tìm.ượ ộ ố ỗ ườ ặ ử ụ ề

c.  N i dungộ

1. Khái ni m c  s  d  li u (CSDL)ệ ơ ở ữ ệ
M t b ng tính c a Excel có th  coi là m t c  s  d  li u (CSDL) vì CSDL là m t t p h pộ ả ủ ể ộ ơ ở ữ ệ ộ ậ ợ  
danh sách g m nhi u dòng và nhi u c t. M i c t có tên c t  g i là tr ng (Field), m i dòngồ ề ệ ộ ỗ ộ ộ ọ ườ ỗ  
còn g i là m u tin (record) hay b . Dòng đ u tiên c a CSDL g i là dòng tiêu đ  (Headerọ ẫ ộ ầ ủ ọ ề  
row). V i CSDL ta có th  s p x p danh sách theo 1 th  t  tăng d n (Ascending) nh  1ớ ể ắ ế ứ ự ầ ư 2, 
…n hay theo t  đi n: Aự ể B… hay a  b…z hay gi m d n (Descending) nh  :ả ầ ư  
10 9….-->1  ho c Zặ  Y… A theo 1 c t ( g i là khóa s p x p : key) (theo m t hayộ ọ ắ ế ộ  
nhi u khóa), có th  tìm ki m, trích l c thông tin h u ích, t ng h p thông tin…t  CSDL.ề ể ế ọ ữ ổ ợ ừ

2. S p x p c  s  d  li u (CSDL) (Sort)ắ ế ơ ở ữ ệ
Là thao tác s p x p các m u tin c a b ng tính theo th  t  tăng hay gi m d n d a vào n iắ ế ẫ ủ ả ứ ự ả ầ ự ộ  
dung c a 1  hay nhiêu c t g i là khóa s p x p.ủ ộ ọ ắ ế
Đ  minh h a cho thao tác s p x p các m u tin trong b ng tính, chúng ta hãy xem ví dể ọ ắ ế ẫ ả ụ 
minh h a sauọ
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Bài t p rèn luy n sort (d a vào b ng tính trên)ậ ệ ự ả
Câu 1: Hãy s p x p b ng tính gi m d n v i khóa s p x p là c t c ngắ ế ả ả ầ ớ ắ ế ộ ộ
Câu 2: Hãy s p x p b ng tính tăng d n d n v i khóa s p x p là Đ n giáắ ế ả ầ ầ ớ ắ ế ơ
Câu 3: Hãy s p x p b ng tính gi m d n v i khóa s p x p là c t Thuắ ế ả ả ầ ớ ắ ế ộ ế
Th c hi n s p x p theo 2 khóa. Ví dự ệ ắ ế ụ

H c viên hãy th c t p rèn luy n s p x p nh  sauọ ự ậ ệ ắ ế ư
Câu 1: Hãy s p x p b ng tính tăng d n v i khóa s p x p là c t Tên, n u trùng tên thì s pắ ế ả ầ ớ ắ ế ộ ế ắ  
x p theo c t H  tăng d nế ộ ọ ầ
Câu 2: Hãy s p x p b ng tính tăng d n v i khóa s p x p là c t phái, n u trùng phái thìắ ế ả ầ ớ ắ ế ộ ế  
s p x p theo c t Tên tăng d nắ ế ộ ầ
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Câu 3: Hãy s p x p b ng tính gi m d n v i khóa s p x p là c t ĐTB, n u trùng ĐTB thìắ ế ả ả ầ ớ ắ ế ộ ế  
s p x p theo c t Tên tăng d nắ ế ộ ầ

3. Rút trích d  li u (Filter)ữ ệ
Đây là ch c năng có ý nghĩa thi t th c cho vi c qu n lí CSDL trong công tác tuy n sinh,ứ ế ự ệ ả ể  
qu n lí sinh viên, cán b  CNV t i các tr ng h c, c  quan, qu n lí mua bán bán hàng, v tả ộ ạ ườ ọ ơ ả ậ  
t , s n xu t kinh doanh t i các doanh nghi p, s n xu t…. T  danh sách ban đ u (CSDL)ư ả ấ ạ ệ ả ấ ừ ầ  
ta có th  trích l c ra thông tin h u ích, m t danh sách th a m n m t đi u ki n nào đó.ể ọ ữ ộ ỏ ả ộ ề ệ
Ví d  t  danh sách SV ban đ u ta có th  trích l c danh sách SV đ u, r t, có h c b ng,…ụ ừ ầ ể ọ ậ ớ ọ ổ

3.1 AutoFillter  : (t  đ ng trích l c)ự ộ ọ

AutoFillter giúp ta nhanh chóng l c ra m t danh sách ch  g m các dòng (m u tin)ọ ộ ỉ ồ ẫ  
th a đi u ki n ngay t i vùng hi n th  c a danh sách ban đ u.ỏ ề ệ ạ ể ị ủ ầ

Tr ng h p 1: Trích l c các dòng th a m n 1 đi u ki n chính xác.  ta có ví d  sauườ ợ ọ ỏ ả ề ệ ụ
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 Tr ng h p trích ra thông tin mà giá tr  là 1 ph n c a thông tin trong c t . ườ ợ ị ầ ủ ộ
Ví d :  Trích ra danh sách HS  có h  là Phan  ( liên quan c t H )ụ ọ ộ ọ
Cách gi i quy t: Th c hi n b c 1 và b c 2 nh  trên. B c 3 click ch n hình tam giác c tả ế ự ệ ướ ướ ư ướ ọ ộ  
H  ọ click ch n custom.ọ

Ghi chú
mu n hi n l i tòan b  danh sách, b n click hình tam giácố ệ ạ ộ ạ  
c a c t v a trích l c r i click ch n Allủ ộ ừ ọ ồ ọ

Tr ng h p trích l c thông tin v i 2 đi u ki n ch  liên quan 1 c tườ ợ ọ ớ ề ệ ỉ ộ
Cách gi i quy t : click hình tam giác và click ch n custom và s  d ng đi u ki n And và ORả ế ọ ử ụ ề ệ

Ví d  1ụ : Trích l c danh sách HS tên Minh ho c tên Anh. Th c hi n b c 1 và  2 nh  trênọ ặ ự ệ ướ ư

B c 3:  click hình tam giác c t Tên --> ch n custom hi n ra h p th ai sauướ ộ ọ ệ ộ ọ
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Ví d  2:ụ  Trích l c danh sách HS có đi m trung bình t  5 đ n 8, 2 đi uọ ể ừ ế ề  
ki n này (ĐTB >=5 và ĐTB <=8) ch  liên quan đ n thông tin c a 1 c tệ ỉ ế ủ ộ  
ĐTB nên ta áp d ng cách gi i quy t nh  trên:  ụ ả ế ư Th c hi n b c 1 và  2ự ệ ướ  
nh  trên.ư
B c 3:ướ  click hình tam giác c t ĐTB r i click ch n Custom ộ ồ ọ  hi n raệ  
h p th ai sau. ộ ọ
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Bài t p áp d ng:ậ ụ  S  d ng d  li u đã nh p  ví d  ử ụ ữ ệ ậ ở ụ

Câu 1:  Trích l c danh sách HS l p A ho c l p B. Chép danh sách  sau khi trích l c quaọ ớ ặ ớ ọ  
sheet2 r i đ t tên sheet2 là LOPABồ ặ

Câu 2:  Trích l c danh sách HS có h  Phan ho c h  Lê . Chép danh sách  sau khi trích l cọ ọ ặ ọ ọ  
qua sheet3 r i đ t tên sheet3 là PHAN-LEồ ặ

Câu 3:  Trích l c danh sách HS có đi m TH t  5 đ n 7. Chép danh sách  sau khi trích l cọ ể ừ ế ọ  
qua sheet4 r i đ t tên sheet4 là TB5 den 7ồ ặ

Câu 4:  Trích l c danh sách HS có h  là Nguy n. Chép danh sách  sau khi trích l c quaọ ọ ễ ọ  
sheet5 r i đ t tên sheet5 là HoNguyenồ ặ

Câu 5:  Trích l c danh sách HS có tên b t đ u là L.ọ ắ ầ

Tr ng h p trích l c thông tin v i 2 đi u ki n liên quan 2 c tườ ợ ọ ớ ề ệ ộ
Cách gi i quy t: Trích l c 2 l n ho c trích l c nâng caoả ế ọ ầ ặ ọ

Ví d  1ụ : Trích l c danh sách HS nam l p A. đi u ki n 1: HS nam, đi u ki n 2: L p Aọ ớ ề ệ ề ệ ớ
Th c hi n b c 1 và b c 2 nh  trên.  B c 3 nh  sauự ệ ướ ướ ư ướ ư
B c 3.1:  trích l c HS nam = cách click hình tam giác c t phái, click ch n namướ ọ ộ ọ
B c 3.2:  trích l c HS l p A = cách click hình tam giác c t L p, click ch n Aướ ọ ớ ộ ớ ọ

Ví d  2ụ : Trích l c danh sách HS n  có đi m TB t  7 tr  lên. đi u ki n 1: HS n , đi u ki nọ ữ ể ừ ở ề ệ ữ ề ệ  
2: ĐTB >=7
Th c hi n b c 1 và nh  trên. ự ệ ướ ư
B c 3.1:  trích l c HS n  = cách click hình tam giác c t phái, click ch n nướ ọ ữ ộ ọ ữ
B c 3.2:  trích l c ĐTB> = 7 b ng cách click hình tam giác c t ĐTB, click ch n customướ ọ ằ ộ ọ

Bài t p rèn luy nậ ệ
Câu 1:  Trích l c danh sách HS l p A ho c l p B. Chép danh sách  sau khi trích l c quaọ ớ ặ ớ ọ  
sheet2 r i đ t tên sheet2 là LOPABồ ặ
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Câu 2:
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Ôn t p t  ki m traậ ự ể
1. S p x p b ng tính theo 1 c t nào đó trong Excel, ta dùng:ắ ế ả ộ

a. Data > Sort... b. Tool > Sort... c. Format > Sort... d. C  3 đ u sai. ả ề

2. Trong Excel đ  v  đ  th , sau khi nh p b ng d  li u, ta ch n:ể ẽ ồ ị ậ ả ữ ệ ọ
a. Format > Chart b. Insert > Graph c. Insert > Chart d. C  a, b, c đ u sai.ả ề

3. Trong Excel đ  rút trích (l c) nh ng dòng th a mãn 1 đi u ki n nào đó ta dùng:ể ọ ữ ỏ ề ệ
a. Data > Filter > AutoFilter b. Data\ Filter\ Advenced Filter
c. C  a, b đ u sai. ả ề d. C  a, b đ u đúng.ả ề

4. Đ  rút trích d  li u ta ch n:ể ữ ệ ọ
a. Data > Sort b. Data > Filter c. Tool > Sort d. Data > Group
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